summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam2021-08-02 00:04:19 +0000
committerSam2021-08-02 00:04:19 +0000
commit4725165ffe1723e07a9e7dbdb5211d15583c0ef3 (patch)
tree98fc18e225500484992c3ab03ec2cea60512db46
downloadaur-4725165ffe1723e07a9e7dbdb5211d15583c0ef3.tar.gz
wip
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD43
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ca3313095392
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = crun-git
+ pkgdesc = A fast and lightweight fully featured OCI runtime and C library for running containers
+ pkgver = 0.21.r1.g399b102
+ pkgrel = 1
+ url = https://github.com/containers/crun.git
+ arch = any
+ license = GPL2
+ makedepends = libtool
+ makedepends = python3
+ makedepends = go-md2man
+ makedepends = git
+ depends = yajl
+ depends = systemd-libs
+ depends = libcap
+ depends = libseccomp
+ provides = crun
+ conflicts = crun
+ source = git+https://github.com/containers/crun.git
+ sha256sums = SKIP
+
+pkgname = crun-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..209eaaefe67f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0a74c5836e19
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: samarthj <dev@samarthj.com>
+# Contributor: Nazar Mishturak <nazarmx@gmail.com"
+# Contributor: hexchian <i at hexchain dot org>
+
+# shellcheck disable=2034,2154
+
+pkgname=crun-git
+_pkgname=crun
+pkgver=0.21.r1.g399b102
+pkgrel=1
+pkgdesc="A fast and lightweight fully featured OCI runtime and C library for running containers"
+url="https://github.com/containers/crun"
+arch=('any')
+depends=('yajl' 'systemd-libs' 'libcap' 'libseccomp')
+makedepends=('libtool' 'python3' 'go-md2man' 'git')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+url="https://github.com/containers/$_pkgname.git"
+license=('GPL2')
+source=("git+$url")
+sha256sums=('SKIP')
+
+prepare() {
+ cd "$srcdir/$_pkgname" || exit 1
+ git submodule update --recursive
+}
+
+pkgver() {
+ cd "$srcdir/$_pkgname" || exit 1
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/$_pkgname" || exit 1
+ ./autogen.sh
+ ./configure --prefix=/usr --enable-dynamic
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname" || exit 1
+ make DESTDIR="$pkgdir" install
+}