summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam2021-07-08 03:23:29 -0700
committerSam2021-07-08 03:23:29 -0700
commit706b50ab7697b8306388b288217dfd63931560bd (patch)
tree0918fe968af3a4d13688fe5232ee2a6b2dadd71b
parent5090eb12c1d9dd8e36481a0744fa589ba18f959d (diff)
downloadaur-706b50ab7697b8306388b288217dfd63931560bd.tar.gz
update crun-git deps and conflicts
Signed-off-by: Sam <dev@samarthj.com>
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD56
2 files changed, 31 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 30e2c9cab13e..2adad254db28 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,21 @@
pkgbase = crun-git
pkgdesc = A fast and lightweight fully featured OCI runtime and C library for running containers
- pkgver = 0.9.1.r35.g423bc44
+ pkgver = 0.20.1.r17.g0b0b288
pkgrel = 1
- url = https://github.com/containers/crun
- arch = x86_64
- license = GPL3
+ url = https://github.com/containers/crun.git
+ arch = any
+ license = GPL2
makedepends = libtool
makedepends = python3
makedepends = go-md2man
+ makedepends = git
depends = yajl
depends = systemd-libs
depends = libcap
depends = libseccomp
- source = crun-git::git+https://github.com/containers/crun.git
- source = libocispec::git+https://github.com/containers/libocispec.git
- source = runtime-spec::git+https://github.com/opencontainers/runtime-spec.git
- source = image-spec::git+https://github.com/opencontainers/image-spec.git
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
+ provides = crun
+ conflicts = crun
+ source = git+https://github.com/containers/crun.git
sha256sums = SKIP
pkgname = crun-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 45e54489a8d9..d2c96a6d6440 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,53 +1,43 @@
-# Maintainer: Nazar Mishturak <nazarmx@gmail.com"
+# Maintainer: samarthj <dev@samarthj.com>
+# Contributor: Nazar Mishturak <nazarmx@gmail.com"
# Contributor: hexchian <i at hexchain dot org>
+# shellcheck disable=2034,2154
+
pkgname=crun-git
-pkgver=0.9.1.r35.g423bc44
+_pkgname=crun
+pkgver=0.20.1.r17.g0b0b288
pkgrel=1
pkgdesc="A fast and lightweight fully featured OCI runtime and C library for running containers"
url="https://github.com/containers/crun"
-license=('GPL3')
-arch=('x86_64')
+arch=('any')
depends=('yajl' 'systemd-libs' 'libcap' 'libseccomp')
-makedepends=('libtool' 'python3' 'go-md2man')
-source=(
- "$pkgname::git+https://github.com/containers/crun.git"
- "libocispec::git+https://github.com/containers/libocispec.git"
- "runtime-spec::git+https://github.com/opencontainers/runtime-spec.git"
- "image-spec::git+https://github.com/opencontainers/image-spec.git"
-)
-sha256sums=(
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
-)
+makedepends=('libtool' 'python3' 'go-md2man' 'git')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+url="https://github.com/containers/$_pkgname.git"
+license=('GPL2')
+source=("git+$url")
+sha256sums=('SKIP')
prepare() {
- cd $srcdir/libocispec
- git submodule init
- git config submodule.runtime-spec.url $srcdir/runtime-spec
- git config submodule.image-spec.url $srcdir/image-spec
- git submodule update
- cd $srcdir/$pkgname
- git submodule init
- git config submodule.libocispec.url $srcdir/libocispec
- git submodule update
+ cd "$srcdir/$_pkgname" || exit 1
+ git submodule update --recursive
}
pkgver() {
- cd $pkgname
+ cd "$srcdir/$_pkgname" || exit 1
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd $pkgname
- ./autogen.sh
- ./configure --prefix=/usr
- make
+ cd "$srcdir/$_pkgname" || exit 1
+ ./autogen.sh
+ ./configure --prefix=/usr --enable-dynamic
+ make
}
package() {
- cd $pkgname
- make DESTDIR="$pkgdir" install
+ cd "$srcdir/$_pkgname" || exit 1
+ make DESTDIR="$pkgdir" install
}