summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbytedream2023-08-07 17:30:35 +0200
committerbytedream2023-08-07 17:30:35 +0200
commitbf9f01dd3ccfc047e864cc4cabef6d9849de8b79 (patch)
treeacfdaf1a31bd664d6fddd893c1af61be4b22ba4c
downloadaur-bf9f01dd3ccfc047e864cc4cabef6d9849de8b79.tar.gz
Update to version 3.0.0
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD40
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..13802c76d82a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = crunchy-cli-bin
+ pkgdesc = Command-line downloader for Crunchyroll
+ pkgver = 3.0.0
+ pkgrel = 1
+ url = https://github.com/crunchy-labs/crunchy-cli
+ arch = x86_64
+ license = MIT
+ depends = ffmpeg
+ noextract = manpages.zip
+ noextract = completions.zip
+ source = crunchy-cli::https://github.com/crunchy-labs/crunchy-cli/releases/download/v3.0.0/crunchy-cli-v3.0.0-linux-x86_64
+ source = manpages.zip::https://github.com/crunchy-labs/crunchy-cli/releases/download/v3.0.0/crunchy-cli-v3.0.0-manpages.zip
+ source = completions.zip::https://github.com/crunchy-labs/crunchy-cli/releases/download/v3.0.0/crunchy-cli-v3.0.0-completions.zip
+ source = LICENSE::https://raw.githubusercontent.com/crunchy-labs/crunchy-cli/v3.0.0/LICENSE
+ sha256sums = 743cb45ca4cea06fd120eae2d355a1097e09f162ab2c6f59d6b4e2246af08663
+ sha256sums = 80af4ab47fb3be17b459c4af12881ec81819cfb73ba94ed540cca0f486e39c9f
+ sha256sums = 8ed0fb0d3186408e09636ceeb6af7100f269b4e817394f8c6b46a0cd0100caeb
+ sha256sums = 4a5c6b7d6d7e0948869cfc1f92029dbb7503f80cd23878531f6285214e31ea24
+
+pkgname = crunchy-cli-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c4fe70d166cc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: ByteDream
+pkgname=crunchy-cli-bin
+pkgdesc="Command-line downloader for Crunchyroll"
+arch=('x86_64')
+url="https://github.com/crunchy-labs/crunchy-cli"
+license=('MIT')
+
+pkgver=3.0.0
+pkgrel=1
+
+depends=('ffmpeg')
+source=(
+ "crunchy-cli::https://github.com/crunchy-labs/crunchy-cli/releases/download/v${pkgver}/crunchy-cli-v${pkgver}-linux-x86_64"
+ "manpages.zip::https://github.com/crunchy-labs/crunchy-cli/releases/download/v${pkgver}/crunchy-cli-v${pkgver}-manpages.zip"
+ "completions.zip::https://github.com/crunchy-labs/crunchy-cli/releases/download/v${pkgver}/crunchy-cli-v${pkgver}-completions.zip"
+ "LICENSE::https://raw.githubusercontent.com/crunchy-labs/crunchy-cli/v${pkgver}/LICENSE"
+)
+noextract=("manpages.zip" "completions.zip")
+sha256sums=('743cb45ca4cea06fd120eae2d355a1097e09f162ab2c6f59d6b4e2246af08663' '80af4ab47fb3be17b459c4af12881ec81819cfb73ba94ed540cca0f486e39c9f' '8ed0fb0d3186408e09636ceeb6af7100f269b4e817394f8c6b46a0cd0100caeb' '4a5c6b7d6d7e0948869cfc1f92029dbb7503f80cd23878531f6285214e31ea24')
+
+package() {
+ cd "$srcdir"
+
+ # all files in manpages.zip and completions.zip are stored in root of the archive, makepkg extracts them all to $srcdir
+ # which makes it pretty messy. so the extraction is done manually to keep the content of $srcdir structured
+ mkdir manpages completions
+ cd manpages
+ bsdtar -xf ../manpages.zip
+ cd ../completions
+ bsdtar -xf ../completions.zip
+ cd ..
+
+ install -Dm755 crunchy-cli $pkgdir/usr/bin/crunchy-cli
+ install -Dm644 manpages/* -t $pkgdir/usr/share/man/man1
+ install -Dm644 completions/crunchy-cli.bash -t $pkgdir/usr/share/bash-completions/completions/crunchy-cli
+ install -Dm644 completions/_crunchy-cli -t $pkgdir/usr/share/zsh/site-functions/_crunchy-cli
+ install -Dm644 completions/crunchy-cli.fish -t $pkgdir/usr/share/fish/vendor_completions.d/crunchy-cli.fish
+ install -Dm644 LICENSE -t $pkgdir/usr/share/licenses/crunchy-cli/LICENSE
+}
+