summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormutantmonkey2013-03-02 17:53:31 -0500
committermutantmonkey2013-03-02 17:53:31 -0500
commit82e997a9b7c1ed307d5a33fe819152d1a2b96252 (patch)
tree977e799d6c8dc65a65ae50ad92b4ad93f5356969
downloadaur-82e997a9b7c1ed307d5a33fe819152d1a2b96252.tar.gz
import my AUR packages into git
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD39
2 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c7e10ea6bd7c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = crunchyfrog-hg
+ pkgdesc = SQL editor and database schema browser for the GNOME desktop, latest development version
+ pkgver = 722.1648adf08bb3
+ pkgrel = 2
+ url = http://code.google.com/p/crunchyfrog
+ arch = any
+ license = GPL3
+ makedepends = mercurial
+ depends = python2
+ depends = pygtk
+ depends = pygtksourceview2
+ depends = gnome-python
+ depends = gnome-python-desktop
+ depends = python2-configobj
+ depends = python2-cairo
+ depends = python2-xdg
+ depends = python2-sphinx
+ depends = python2-sqlparse
+ optdepends = mysql-python: To handle MySQL Databases,
+ optdepends = python2-psycopg2: To handle PostgreSQL Databases,
+ optdepends = python2-pysqlite: To handle SQLite Databases,
+ optdepends = python2-cx_oracle: To handle Oracle Databases (just for i686),
+ optdepends = kinterbasdb: To handle Firebird Databases
+ optdepends = informixdb: To handle Informix Databases
+ optdepends = sapdb: To handle MaxDB
+ optdepends = ipython2: To use built-in python shell
+ provides = crunchyfrog
+ conflicts = crunchyfrog
+ source = hg+https://code.google.com/p/crunchyfrog
+ sha256sums = SKIP
+
+pkgname = crunchyfrog-hg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0eed3abadc17
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Contributor: MutantMonkey <mutantmonkey@gmail.com>
+pkgname=crunchyfrog-hg
+pkgver=699
+pkgrel=1
+pkgdesc="SQL editor and database schema browser for the GNOME desktop, latest development version"
+url='http://code.google.com/p/crunchyfrog'
+arch=('any')
+license=('GPL3')
+depends=('python2' 'python-configobj' 'pygtk' 'pygtksourceview2' 'pycairo' \
+ 'pyxdg' 'gnome-python' 'gnome-python-desktop' \
+ 'python-sphinx')
+optdepends=('mysql-python: To handle MySQL Databases',
+ 'python-psycopg2: To handle PostgreSQL Databases',
+ 'python-pysqlite: To handle SQLite Databases',
+ 'cx_oracle: To handle Oracle Databases (just for i686)',
+ 'pymssql: To handle Microsoft SQL Server Databases',
+ 'kinterbasdb: To handle Firebird Databases'
+ 'informixdb: To handle Informix Databases'
+ 'sapdb: To handle MaxDB'
+ 'ipython: To use built-in python shell'
+ )
+makedepends=('mercurial')
+provides=('crunchyfrog')
+conflicts=('crunchyfrog')
+source=()
+md5sums=()
+sha256sums=()
+
+_hgroot="https://crunchyfrog.googlecode.com/hg"
+_hgrepo="crunchyfrog"
+
+build() {
+ cd ${srcdir}/${_hgrepo}
+
+ # remove all language files except English since the language is wrong otherwise
+ rm -r po/{cs,da,de,el,es,fi,fr,he,id,it,ja,nl,ru,sv,tr}
+
+ python setup.py install --root=${pkgdir}/ --optimize=1 || return 1
+}