summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLev Levitsky2021-12-10 22:03:21 +0300
committerLev Levitsky2021-12-10 22:03:21 +0300
commitd9d34d18929d88aaf084d2bc71c55e8093fc0a47 (patch)
tree167a463dd3d32b2f0fee938b2c94f40716f0c4dd
parentd4b1035c047e74cfaf8a7f9f5b6e0e5aeceb720b (diff)
downloadaur-d9d34d18929d88aaf084d2bc71c55e8093fc0a47.tar.gz
4.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fcbad650da9e..67d157bee391 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,14 @@
pkgbase = crux-toolkit-bin
pkgdesc = A mass spectrometry analysis toolkit
- pkgver = 4.0.ad795d6
+ pkgver = 4.1.476f22e
pkgrel = 1
url = http://crux.ms
arch = x86_64
- arch = i686
license = Apache
provides = crux-toolkit
conflicts = crux-toolkit-git
- source_x86_64 = https://noble.gs.washington.edu/crux-downloads/daily/crux-4.0.ad795d6.Linux.x86_64.zip
+ source_x86_64 = https://noble.gs.washington.edu/crux-downloads/daily/crux-4.1.476f22e.Linux.x86_64.zip
depends_x86_64 = gcc-libs
- sha256sums_x86_64 = 1e02afd2992373dde49e0dc03f1b0c2ea8819d402ade7c5c578871c3cfc5c2df
- source_i686 = https://noble.gs.washington.edu/crux-downloads/daily/crux-4.0.ad795d6.Linux.x86_64.zip
- depends_i686 = lib32-gcc-libs
- sha256sums_i686 = 4185450c8c77f3e27a5f98d3b5b911bf2331d86af9bc62e94e0dd6b2d73419ff
+ sha256sums_x86_64 = 3199bd324f31ee9bb1a6a8b02f7e3f1efd08d0dd53c1008a59be13590ac176b6
pkgname = crux-toolkit-bin
diff --git a/PKGBUILD b/PKGBUILD
index 45ef785c2916..7a676f82d97e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
# Maintainer: Lev Levitsky <levlev at mail.ru>
pkgname=crux-toolkit-bin
-pkgver=4.0.ad795d6
+pkgver=4.1.476f22e
+_majorver="${pkgver%.*}"
pkgrel=1
pkgdesc="A mass spectrometry analysis toolkit"
-arch=('x86_64' 'i686')
+arch=('x86_64')
url="http://crux.ms"
license=('Apache')
depends_x86_64=('gcc-libs')
@@ -11,11 +12,9 @@ depends_i686=('lib32-gcc-libs')
provides=("${pkgname%-bin}")
conflicts=("${pkgname%-bin}-git")
source_x86_64=("https://noble.gs.washington.edu/crux-downloads/daily/crux-${pkgver}.Linux.${CARCH}.zip")
-source_i686=("https://noble.gs.washington.edu/crux-downloads/daily/crux-${pkgver}.Linux.${CARCH}.zip")
-sha256sums_x86_64=('1e02afd2992373dde49e0dc03f1b0c2ea8819d402ade7c5c578871c3cfc5c2df')
-sha256sums_i686=('4185450c8c77f3e27a5f98d3b5b911bf2331d86af9bc62e94e0dd6b2d73419ff')
+sha256sums_x86_64=('3199bd324f31ee9bb1a6a8b02f7e3f1efd08d0dd53c1008a59be13590ac176b6')
package() {
- install -D -t "${pkgdir}/usr/bin" "crux-4.0.Linux.${CARCH}/bin/crux"
+ install -D -t "${pkgdir}/usr/bin" "crux-${_majorver}.Linux.${CARCH}/bin/crux"
}