summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2016-03-13 04:30:53 -0700
committerAndy Weidenbaum2016-03-13 04:30:53 -0700
commit7b50958a050819a8b9750be20fef3405b1f8a6fd (patch)
treed9e838633ee66679a00089911fc876b8793f88b3
downloadaur-7b50958a050819a8b9750be20fef3405b1f8a6fd.tar.gz
Initial import
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD50
2 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2f945deb098b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+# Generated by mksrcinfo v8
+# Sun Mar 13 11:30:05 UTC 2016
+pkgbase = cryfs
+ pkgdesc = Cryptographic filesystem for the cloud
+ pkgver = 0.9.3.alpha
+ pkgrel = 1
+ url = https://www.cryfs.org
+ arch = i686
+ arch = x86_64
+ license = LGPL3
+ makedepends = cmake
+ makedepends = git
+ makedepends = make
+ depends = boost
+ depends = boost-libs
+ depends = crypto++
+ depends = curl
+ depends = fuse
+ depends = openssl
+ depends = python2
+ source = cryfs-0.9.3.alpha.tar.gz::https://codeload.github.com/cryfs/cryfs/tar.gz/0.9.3-alpha
+ source = git+https://github.com/cryfs/cryfs.wiki
+ sha256sums = 136b3009b9a352cd891d41f2cd009a340616105310fedddaa8e678ec23900be3
+ sha256sums = SKIP
+
+pkgname = cryfs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a07a7a7d0dae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=cryfs
+pkgver=0.9.3.alpha
+pkgrel=1
+pkgdesc="Cryptographic filesystem for the cloud"
+arch=('i686' 'x86_64')
+depends=('boost'
+ 'boost-libs'
+ 'crypto++'
+ 'curl'
+ 'fuse'
+ 'openssl'
+ 'python2')
+makedepends=('cmake' 'git' 'make')
+url="https://www.cryfs.org"
+license=('LGPL3')
+source=($pkgname-$pkgver.tar.gz::https://codeload.github.com/cryfs/$pkgname/tar.gz/0.9.3-alpha
+ git+https://github.com/cryfs/cryfs.wiki)
+sha256sums=('136b3009b9a352cd891d41f2cd009a340616105310fedddaa8e678ec23900be3'
+ 'SKIP')
+
+build() {
+ cd "$srcdir/$pkgname-0.9.3-alpha"
+
+ msg2 'Building...'
+ mkdir cmake && cd cmake
+ cmake -DCMAKE_BUILD_TYPE=Release -DBUILD_TESTING=off ..
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-0.9.3-alpha"
+
+ msg2 'Installing license...'
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+
+ msg2 'Installing documentation...'
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
+
+ msg2 'Installing wiki...'
+ cp -dpr --no-preserve=ownership "$srcdir/$pkgname.wiki" \
+ "$pkgdir/usr/share/doc/$pkgname/wiki"
+
+ msg2 'Installing...'
+ make DESTDIR="$pkgdir" install -C cmake
+
+ msg2 'Cleaning up pkgdir...'
+ find "$pkgdir" -type d -name .git -exec rm -r '{}' +
+}