summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjdn062016-03-13 10:29:04 +0100
committerjdn062016-03-13 10:29:04 +0100
commit93d3bb006562c47408b55ce1800d8b67b80137d9 (patch)
tree92ac1210562f36ecd3fb1c383388c095faced299
downloadaur-93d3bb006562c47408b55ce1800d8b67b80137d9.tar.gz
Initial import
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD38
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..414284de7fc5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Sun Mar 13 09:28:07 UTC 2016
+pkgbase = cryfs-git
+ pkgdesc = CryFS encrypts your files, so you can safely store them anywhere
+ pkgver = 2016.03
+ pkgrel = 1
+ url = https://www.cryfs.org
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ makedepends = cmake
+ makedepends = boost
+ depends = fuse
+ depends = python2
+ depends = openssl
+ depends = crypto++
+ provides = cryfs
+ conflicts = cryfs
+ source = cryfs::git://github.com/cryfs/cryfs.git
+ sha256sums = SKIP
+
+pkgname = cryfs-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..163898035a0d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: jdn06 <jdn06.jdn06@outlook.fr>
+
+pkgname=cryfs-git
+_pkgname=cryfs
+pkgver=2016.03
+pkgrel=1
+pkgdesc="CryFS encrypts your files, so you can safely store them anywhere"
+arch=('i686' 'x86_64')
+url="https://www.cryfs.org"
+license=('LGPL')
+depends=('fuse' 'python2' 'openssl' 'crypto++')
+makedepends=('git' 'cmake' 'boost')
+provides=('cryfs')
+conflicts=('cryfs')
+
+source=("$_pkgname"::"git://github.com/$_pkgname/$_pkgname.git")
+sha256sums=(SKIP)
+
+pkgver() {
+ cd ${_pkgname}
+ git describe --tags
+}
+
+prepare() {
+ cd "$srcdir/$_pkgname"
+ mkdir cmake && cd cmake
+ cmake ..
+}
+
+build() {
+ cd "$srcdir/$_pkgname/cmake"
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname/cmake"
+ make DESTDIR="$pkgdir/" PREFIX="/usr" install
+}