summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjdn062016-03-13 19:42:38 +0100
committerjdn062016-03-13 19:42:38 +0100
commitee0e8f6f0ea5c2d251489e8a157ab6e9ccc54b38 (patch)
tree493d64c556a3bf24fdbde1d8db8a8b978e73dcb1
parenta30ca38f214ec099a32019d58c53ee21d5d21b32 (diff)
downloadaur-ee0e8f6f0ea5c2d251489e8a157ab6e9ccc54b38.tar.gz
Correct path & dependencies
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9d1920131b9f..28c7b9df25c1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sun Mar 13 10:40:27 UTC 2016
+# Sun Mar 13 18:42:08 UTC 2016
pkgbase = cryfs-git
pkgdesc = CryFS encrypts your files, so you can safely store them anywhere
pkgver = 2016.03
@@ -7,14 +7,15 @@ pkgbase = cryfs-git
url = https://www.cryfs.org
arch = i686
arch = x86_64
- license = LGPL
+ license = LGPL3
makedepends = git
makedepends = cmake
makedepends = boost
- makedepends = python2
+ makedepends = python
depends = fuse
depends = openssl
depends = crypto++
+ depends = curl
provides = cryfs
conflicts = cryfs
source = cryfs::git://github.com/cryfs/cryfs.git
diff --git a/PKGBUILD b/PKGBUILD
index 1211b2fc3560..8de90bc66562 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,9 +7,9 @@ pkgrel=1
pkgdesc="CryFS encrypts your files, so you can safely store them anywhere"
arch=('i686' 'x86_64')
url="https://www.cryfs.org"
-license=('LGPL')
-depends=('fuse' 'openssl' 'crypto++')
-makedepends=('git' 'cmake' 'boost' 'python2')
+license=('LGPL3')
+depends=('fuse' 'openssl' 'crypto++' 'curl')
+makedepends=('git' 'cmake' 'boost' 'python')
provides=('cryfs')
conflicts=('cryfs')
@@ -24,7 +24,7 @@ pkgver() {
prepare() {
cd "$srcdir/$_pkgname"
mkdir cmake && cd cmake
- cmake ..
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
}
build() {
@@ -34,5 +34,5 @@ build() {
package() {
cd "$srcdir/$_pkgname/cmake"
- make DESTDIR="$pkgdir/" PREFIX="/usr" install
+ make DESTDIR="$pkgdir/" install
}