summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHythlodaeus2016-05-28 23:19:43 +0000
committerHythlodaeus2016-05-28 23:19:43 +0000
commite61de1106859ca8aa0c94b20f05edb4d7f5808eb (patch)
tree7f383fee8ea017d1746a6749ecf3d4b3d4386d96
downloadaur-e61de1106859ca8aa0c94b20f05edb4d7f5808eb.tar.gz
Standard commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD37
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f0c978ebf2b9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = cryptcat
+ pkgdesc = Cryptcat is the standard netcat enhanced with twofish encryption
+ pkgver = 1.2.1
+ pkgrel = 1
+ url = https://cryptcat.sourceforge.net
+ arch = i686
+ arch = x86_64
+ license = GPLv2
+ source = http://downloads.sourceforge.net/project/cryptcat/cryptcat-unix-1.2/cryptcat-unix-1.2.1/cryptcat-unix-1.2.1.tar?r=https%3A%2F%2Fsourceforge.net%2Fprojects%2Fcryptcat%2Ffiles%2Fcryptcat-unix-1.2%2Fcryptcat-unix-1.2.1%2F&ts=1464475005&use_mirror=iweb
+ md5sums = fc4afff350f3dd5e4fe51b0dd01a8e21
+
+pkgname = cryptcat
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..738714aab910
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Hythlodaeus <matteodelseppiaomm@gmail.com>
+pkgname=cryptcat
+pkgver=1.2.1
+pkgrel=1
+epoch=
+pkgdesc="Cryptcat is the standard netcat enhanced with twofish
+encryption"
+arch=(i686 x86_64)
+url="https://cryptcat.sourceforge.net"
+license=('GPLv2')
+groups=()
+depends=()
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("http://downloads.sourceforge.net/project/cryptcat/cryptcat-unix-1.2/cryptcat-unix-1.2.1/cryptcat-unix-1.2.1.tar?r=https%3A%2F%2Fsourceforge.net%2Fprojects%2Fcryptcat%2Ffiles%2Fcryptcat-unix-1.2%2Fcryptcat-unix-1.2.1%2F&ts=1464475005&use_mirror=iweb")
+noextract=()
+md5sums=(fc4afff350f3dd5e4fe51b0dd01a8e21)
+validpgpkeys=()
+
+build() {
+ cd unix
+ make linux
+}
+
+
+package() {
+ cd unix
+ sudo cp -v cryptcat /usr/bin/cryptcat
+}