summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhillip Smith2015-06-02 10:20:02 +1000
committerPhillip Smith2015-06-02 10:20:02 +1000
commit1a3364f99a479a769af9809d012a678fc64440aa (patch)
tree52aca6a21ce07bdaf3ffbc0d7a07efa4dd7b7dad
downloadaur-1a3364f99a479a769af9809d012a678fc64440aa.tar.gz
initial ommit
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD54
-rw-r--r--cryptkeeper-0.9.5-add-unistd-to-lsof.patch10
-rw-r--r--cryptkeeper-0.9.5-fix-linking.patch11
-rw-r--r--cryptkeeper.desktop12
6 files changed, 111 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..534379a5e923
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = cryptkeeper
+ pkgdesc = A Linux system tray applet that manages EncFS encrypted folders.
+ pkgver = 0.9.5
+ pkgrel = 5
+ url = http://tom.noflag.org.uk/cryptkeeper.html
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = autoconf
+ depends = gtk2
+ depends = gconf
+ depends = encfs
+ source = http://tom.noflag.org.uk/cryptkeeper/cryptkeeper-0.9.5.tar.gz
+ source = cryptkeeper.desktop
+ source = cryptkeeper-0.9.5-fix-linking.patch
+ source = cryptkeeper-0.9.5-add-unistd-to-lsof.patch
+ md5sums = d02918b2058854177d2f59b837c2743f
+ md5sums = 37484e52a1557a18c0cc2443b3104007
+ md5sums = aa864cea6a81ef8e8cb3efa5ef2b9541
+ md5sums = 2e21a1e82942213108774d768e12e4ee
+
+pkgname = cryptkeeper
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b8427da31a1d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+/cryptkeeper-*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..33a0cd03f75a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Phillip Smith <fukawi2@NO-SPAM.gmail.com>
+# http://github.com/fukawi2/aur-packages
+# Contributor: Paolo Stivanin aka Polslinux <admin AT polslinux DOT it>
+# pkgrel3 patcher: Ivan de Jesús Pompa García <ivan.pompa@gmx.com>
+
+### I AM ONLY THE PACKAGER, NOT THE DEVELOPER
+### Please ask support questions about this software in one of:
+### 1) The AUR comments; OR
+### 2) Upstream forums/maillist etc; OR
+### 3) The ArchLinux forums
+### I do not always know enough about the software itself, or don't have the
+### time to promptly respond to direct emails.
+### If you have found a problem with the package/PKGBUILD (as opposed to
+### the software) then please do email me or post an AUR comment.
+
+pkgname=cryptkeeper
+pkgver=0.9.5
+pkgrel=5
+pkgdesc="A Linux system tray applet that manages EncFS encrypted folders."
+arch=(i686 x86_64)
+url="http://tom.noflag.org.uk/cryptkeeper.html"
+license=('GPL3')
+depends=('gtk2' 'gconf' 'encfs')
+makedepends=('autoconf')
+source=("http://tom.noflag.org.uk/$pkgname/$pkgname-$pkgver.tar.gz"
+ "cryptkeeper.desktop"
+ "cryptkeeper-0.9.5-fix-linking.patch"
+ "cryptkeeper-0.9.5-add-unistd-to-lsof.patch")
+md5sums=('d02918b2058854177d2f59b837c2743f'
+ '37484e52a1557a18c0cc2443b3104007'
+ 'aa864cea6a81ef8e8cb3efa5ef2b9541'
+ '2e21a1e82942213108774d768e12e4ee')
+
+prepare() {
+ cd "$srcdir"/$pkgname-$pkgver
+ patch -Np1 < "$srcdir"/cryptkeeper-0.9.5-fix-linking.patch
+ patch -Np1 < "$srcdir"/cryptkeeper-0.9.5-add-unistd-to-lsof.patch
+}
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+
+ make DESTDIR="$pkgdir" install
+
+ install -D -m644 "$srcdir"/$pkgname.desktop "$pkgdir"/usr/share/applications/${pkgname}.desktop
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/cryptkeeper-0.9.5-add-unistd-to-lsof.patch b/cryptkeeper-0.9.5-add-unistd-to-lsof.patch
new file mode 100644
index 000000000000..f24aee67e5ee
--- /dev/null
+++ b/cryptkeeper-0.9.5-add-unistd-to-lsof.patch
@@ -0,0 +1,10 @@
+--- cryptkeeper-0.9.5/src/lsof.cpp.old 2012-04-22 10:00:24.655295117 -0500
++++ cryptkeeper-0.9.5/src/lsof.cpp 2012-04-22 10:00:35.838624366 -0500
+@@ -21,6 +21,7 @@
+ #include <vector>
+ #include <assert.h>
+ #include <cstring>
++#include <unistd.h>
+ #include "lsof.h"
+
+ fsuser::fsuser(const char *pid, const char *name)
diff --git a/cryptkeeper-0.9.5-fix-linking.patch b/cryptkeeper-0.9.5-fix-linking.patch
new file mode 100644
index 000000000000..30634ce1caac
--- /dev/null
+++ b/cryptkeeper-0.9.5-fix-linking.patch
@@ -0,0 +1,11 @@
+--- cryptkeeper-0.9.5/configure.ac.old 2010-07-25 13:03:02.000000000 +0100
++++ cryptkeeper-0.9.5/configure.ac 2010-07-25 13:03:12.000000000 +0100
+@@ -22,7 +22,7 @@ PKG_CHECK_MODULES(DEP, gtk+-2.0 >= 2.8 g
+
+ CFLAGS="$CFLAGS $DEP_CFLAGS $GNOME_KEYRING_CFLAGS"
+ CXXFLAGS="$CFLAGS"
+-LIBS="$DEP_LIBS $GNOME_KEYRING_LIBS"
++LIBS="$DEP_LIBS $GNOME_KEYRING_LIBS -lX11"
+
+ #AC_PROG_LIBTOOL
+
diff --git a/cryptkeeper.desktop b/cryptkeeper.desktop
new file mode 100644
index 000000000000..52901d6a3c04
--- /dev/null
+++ b/cryptkeeper.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Name=cryptkeeper
+GenericName="Cryptkeeper manages EncFs encrypted folders"
+GenericName[de]="Cryptkeeper verwaltet verschluesselte Ordner"
+Comment="Cryptkeeper is a FreeDesktop.org (KDE, Gnome, XFce, etc.) system tray applet that manages EncFS encrypted folders.
+Exec=cryptkeeper
+Icon=/usr/share/pixmaps/cryptkeeper.png
+Terminal=0
+Type=Application
+# Categories=Qt;KDE;Math;Education
+Categories=System
+