summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2016-09-17 13:21:32 -0700
committerAndy Weidenbaum2016-09-17 13:21:32 -0700
commit0c3cab41ea1438084a166ec7d1d432ec86944f03 (patch)
treeaeff0bdad33e97686a149e59f9012773dab0668b
downloadaur-0c3cab41ea1438084a166ec7d1d432ec86944f03.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD65
-rw-r--r--libcrypto++.pc11
3 files changed, 98 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..989a01cd6fc2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Sat Sep 17 20:21:23 UTC 2016
+pkgbase = crypto++-git
+ pkgdesc = C++ Class Library of Cryptographic Schemes
+ pkgver = 20160916
+ pkgrel = 1
+ url = https://github.com/weidai11/cryptopp
+ arch = i686
+ arch = x86_64
+ license = custom:Boost
+ makedepends = git
+ makedepends = make
+ depends = gcc-libs
+ provides = crypto++
+ conflicts = crypto++
+ source = crypto++::git+https://github.com/weidai11/cryptopp
+ source = libcrypto++.pc
+ sha256sums = SKIP
+ sha256sums = a5e467460494a97ada513a0c22f735cf5aade9cec75e0b4c46055ecd4b32fea6
+
+pkgname = crypto++-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2eab8206c359
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,65 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+# Contributor: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: Alexander Rødseth <rodseth@gmail.com>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Kritoke <kritoke@gamebox.net>
+# Contributor: jlvsimoes <jlvsimoes@oninet.pt>
+
+pkgname=crypto++-git
+pkgver=20160916
+pkgrel=1
+pkgdesc="C++ Class Library of Cryptographic Schemes"
+arch=('i686' 'x86_64')
+depends=('gcc-libs')
+makedepends=('git' 'make')
+url="https://github.com/weidai11/cryptopp"
+license=('custom:Boost')
+source=(${pkgname%-git}::git+https://github.com/weidai11/cryptopp
+ 'libcrypto++.pc')
+sha256sums=('SKIP'
+ 'a5e467460494a97ada513a0c22f735cf5aade9cec75e0b4c46055ecd4b32fea6')
+provides=('crypto++')
+conflicts=('crypto++')
+
+pkgver() {
+ cd ${pkgname%-git}
+ git log -1 --format="%cd" --date=short | sed "s|-||g"
+}
+
+prepare() {
+ cd ${pkgname%-git}
+
+ msg2 'Fixing GNUmakefile...'
+ sed -i 's/^CXXFLAGS/#CXXFLAGS/' GNUmakefile
+}
+
+build() {
+ cd ${pkgname%-git}
+
+ msg2 'Building...'
+ export CXXFLAGS="$CXXFLAGS -DNDEBUG -fPIC"
+ make -j$(($(nproc)/2)) dynamic static
+}
+
+check() {
+ cd ${pkgname%-git}
+
+ msg2 'Testing...'
+ make -j$(($(nproc)/2)) test
+}
+
+package() {
+ cd ${pkgname%-git}
+
+ msg2 'Installing license...'
+ install -Dm 644 License.txt -t "$pkgdir/usr/share/licenses/${pkgname%-git}"
+
+ msg2 'Installing pkgconfig file...'
+ install -Dm 644 "$srcdir/libcrypto++.pc" -t "$pkgdir/usr/lib/pkgconfig"
+
+ msg2 'Installing...'
+ make DESTDIR="$pkgdir" PREFIX=/usr install
+
+ msg2 'Cleaning up pkgdir...'
+ rm -rf "$pkgdir/usr/bin"
+}
diff --git a/libcrypto++.pc b/libcrypto++.pc
new file mode 100644
index 000000000000..158c67f8ccec
--- /dev/null
+++ b/libcrypto++.pc
@@ -0,0 +1,11 @@
+# Written by Alexander Rødseth <rodseth@gmail.com>
+
+prefix=/usr
+libdir=${prefix}/lib
+includedir=${prefix}/include
+
+Name: libcrypto++-5.6.4
+Description: Class library of cryptographic schemes
+Version: 5.6.4
+Libs: -L${libdir} -lcryptopp
+Cflags: -I${includedir}