summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin MacMartin2020-11-11 01:03:08 -0500
committerKevin MacMartin2020-11-11 01:03:08 -0500
commit6707d51fe050ba9f34715e9825fd60951373f855 (patch)
tree9c76c4e25c8737f4c8cab768926fe2fd1e2a49b2
parent85801297bbece5182308af0fa1b4a58ccfa517d2 (diff)
downloadaur-6707d51fe050ba9f34715e9825fd60951373f855.tar.gz
Update to the latest version, add a gitignore and drop the man page
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD23
-rw-r--r--cryptobox.153
4 files changed, 17 insertions, 71 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 085406a4469f..8575524bc858 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cryptobox
- pkgdesc = A simple frontend script for creating, mounting and umounting luks encrypted disk images
- pkgver = 20140529.r9.f32decc
- pkgrel = 2
+ pkgdesc = A script that makes it easy to create, mount and unmount encrypted images in Linux using LUKS
+ pkgver = 20201111.r11.da853cb
+ pkgrel = 1
url = https://github.com/prurigro/cryptobox
arch = any
license = GPL3
@@ -10,9 +10,7 @@ pkgbase = cryptobox
depends = cryptsetup
depends = util-linux
source = git://github.com/prurigro/cryptobox.git#branch=master
- source = cryptobox.1
sha512sums = SKIP
- sha512sums = cdbe0bd873401c4d366318cef784969f70004baf7760aadba96c109d3879faa3456f3c0ff00466539a27ff8ad96a785d12cea4376eda4d06999839ba9b3db256
pkgname = cryptobox
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..95b0768e05aa
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.pkg.tar*
+cryptobox
+pkg
+src
diff --git a/PKGBUILD b/PKGBUILD
index 7085fee3ea24..b8e9102c4b82 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,22 @@
-# Maintainer: Prurigro
-# Contributor: Prurigro
+# Maintainer: Kevin MacMartin <prurigro@gmail.com>
pkgname=cryptobox
-pkgver=20140529.r9.f32decc
-pkgrel=2
-pkgdesc="A simple frontend script for creating, mounting and umounting luks encrypted disk images"
-url="https://github.com/prurigro/${pkgname}"
+pkgver=20201111.r11.da853cb
+pkgrel=1
+pkgdesc='A script that makes it easy to create, mount and unmount encrypted images in Linux using LUKS'
+url='https://github.com/prurigro/cryptobox'
license=('GPL3')
depends=('coreutils' 'cryptsetup' 'util-linux')
makedepends=('git')
arch=('any')
-
-source=("git://github.com/prurigro/${pkgname}.git#branch=master" "${pkgname}.1")
-sha512sums=('SKIP' 'cdbe0bd873401c4d366318cef784969f70004baf7760aadba96c109d3879faa3456f3c0ff00466539a27ff8ad96a785d12cea4376eda4d06999839ba9b3db256')
+source=("git://github.com/prurigro/${pkgname}.git#branch=master")
+sha512sums=('SKIP')
pkgver() {
- cd $pkgname
- printf "%s.r%s.%s" "$(git show -s --format=%ci master | sed 's/\ .*//g;s/-//g')" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd $pkgname
+ printf "%s.r%s.%s" "$(git show -s --format=%ci master | sed 's/\ .*//g;s/-//g')" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- install -Dm644 ${pkgname}.1 "${pkgdir}/usr/share/man/man1/${pkgname}.1"
- install -Dm755 ${pkgname}/${pkgname} "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm755 $pkgname/$pkgname "$pkgdir/usr/bin/$pkgname"
}
diff --git a/cryptobox.1 b/cryptobox.1
deleted file mode 100644
index 73685c74a14e..000000000000
--- a/cryptobox.1
+++ /dev/null
@@ -1,53 +0,0 @@
-.\" generated with Ronn/v0.7.3
-.\" http://github.com/rtomayko/ronn/tree/0.7.3
-.
-.TH "CRYPTOBOX" "" "May 2014" "" "cryptobox"
-A wrapper script for \fBcryptsetup\fR that makes it easy to create, mount and unmount encrypted image files using LUKS\.
-.
-.SH "Requirements"
-
-\fBcryptsetup\fR
-.RS 4
-Userspace setup tool for transparent encryption of block devices using\.
-.RE
-.PP
-
-\fButil\-linux\fR
-.RS 4
-Miscellaneous system utilities for Linux, required for \fBlosetup\fR and \fBmkfs\fR\.
-.RE
-.PP
-
-.IP "" 0
-.
-.SH "Usage"
-.
-\fBcryptobox\fR
-.RS 4
-Displays the list of commands
-.RE
-.PP
-
-\fBcryptobox c filename\.img filesystem size\-in\-mb\fR
-.RS 4
-Creates an image file with a given filesystem and size in megabytes\. (eg: \fBcryptobox c myimg\.img ext4 128\fR)
-.RE
-.PP
-
-\fBcryptobox m filename\.img /mount/point\fR
-.RS 4
-Mounts a given image file on a given directory\. (eg: \fBcryptobox m myimg\.img /mnt/cryptoimg\fR)
-.RE
-.PP
-
-\fBcryptobox u /mount/point\fR
-.RS 4
-Unmounts an image file from a given directory\. (eg: \fBcryptobox u /mnt/cryptoimg\fR)
-.RE
-.PP
-
-.SH "Credits"
-Written by Kevin MacMartin: GitHub Projects \fIhttps://github\.com/prurigro?tab=repositories\fR | Arch Linux AUR Packages \fIhttps://aur\.archlinux\.org/packages/?SeB=m&K=prurigro\fR
-.
-.SH "License"
-This script is open source and licensed under the GPLv3 \fIhttp://www\.gnu\.org/copyleft/gpl\.html\fR\.