summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin MacMartin2015-06-10 00:37:47 -0400
committerKevin MacMartin2015-06-10 00:37:47 -0400
commit85801297bbece5182308af0fa1b4a58ccfa517d2 (patch)
tree187123b2f9561688d6e0fdf8c8ec4f9c69c5efcd
downloadaur-85801297bbece5182308af0fa1b4a58ccfa517d2.tar.gz
Initial import into AUR 4
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
-rw-r--r--README.md23
-rw-r--r--cryptobox.153
4 files changed, 119 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..085406a4469f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = cryptobox
+ pkgdesc = A simple frontend script for creating, mounting and umounting luks encrypted disk images
+ pkgver = 20140529.r9.f32decc
+ pkgrel = 2
+ url = https://github.com/prurigro/cryptobox
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = coreutils
+ depends = cryptsetup
+ depends = util-linux
+ source = git://github.com/prurigro/cryptobox.git#branch=master
+ source = cryptobox.1
+ sha512sums = SKIP
+ sha512sums = cdbe0bd873401c4d366318cef784969f70004baf7760aadba96c109d3879faa3456f3c0ff00466539a27ff8ad96a785d12cea4376eda4d06999839ba9b3db256
+
+pkgname = cryptobox
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7085fee3ea24
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Prurigro
+# Contributor: Prurigro
+
+pkgname=cryptobox
+pkgver=20140529.r9.f32decc
+pkgrel=2
+pkgdesc="A simple frontend script for creating, mounting and umounting luks encrypted disk images"
+url="https://github.com/prurigro/${pkgname}"
+license=('GPL3')
+depends=('coreutils' 'cryptsetup' 'util-linux')
+makedepends=('git')
+arch=('any')
+
+source=("git://github.com/prurigro/${pkgname}.git#branch=master" "${pkgname}.1")
+sha512sums=('SKIP' 'cdbe0bd873401c4d366318cef784969f70004baf7760aadba96c109d3879faa3456f3c0ff00466539a27ff8ad96a785d12cea4376eda4d06999839ba9b3db256')
+
+pkgver() {
+ cd $pkgname
+ printf "%s.r%s.%s" "$(git show -s --format=%ci master | sed 's/\ .*//g;s/-//g')" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ install -Dm644 ${pkgname}.1 "${pkgdir}/usr/share/man/man1/${pkgname}.1"
+ install -Dm755 ${pkgname}/${pkgname} "${pkgdir}/usr/bin/${pkgname}"
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..e70f0901e73d
--- /dev/null
+++ b/README.md
@@ -0,0 +1,23 @@
+# Cryptobox #
+
+A wrapper script for **cryptsetup** that makes it easy to create, mount and unmount encrypted image files using LUKS.
+
+## Requirements ##
+
+* **cryptsetup**: Userspace setup tool for transparent encryption of block devices using.
+* **util-linux**: Miscellaneous system utilities for Linux, required for **losetup** and **mkfs**.
+
+## Usage ##
+
+* cryptobox: displays the list of commands
+* cryptobox c filename.img filesystem size-in-mb: creates an image file with a given filesystem and size in megabytes. (eg: `cryptobox c myimg.img ext4 128`)
+* cryptobox m filename.img /mount/point: mounts a given image file on a given directory. (eg: `cryptobox m myimg.img /mnt/cryptoimg`)
+* cryptobox u /mount/point: unmounts an image file from a given directory. (eg: `cryptobox u /mnt/cryptoimg`)
+
+## Credits ##
+
+Written by Kevin MacMartin: [GitHub Projects](https://github.com/prurigro?tab=repositories) | [Arch Linux AUR Packages](https://aur.archlinux.org/packages/?SeB=m&K=prurigro)
+
+## License ##
+
+This script is open source and licensed under the [GPLv3](http://www.gnu.org/copyleft/gpl.html).
diff --git a/cryptobox.1 b/cryptobox.1
new file mode 100644
index 000000000000..73685c74a14e
--- /dev/null
+++ b/cryptobox.1
@@ -0,0 +1,53 @@
+.\" generated with Ronn/v0.7.3
+.\" http://github.com/rtomayko/ronn/tree/0.7.3
+.
+.TH "CRYPTOBOX" "" "May 2014" "" "cryptobox"
+A wrapper script for \fBcryptsetup\fR that makes it easy to create, mount and unmount encrypted image files using LUKS\.
+.
+.SH "Requirements"
+
+\fBcryptsetup\fR
+.RS 4
+Userspace setup tool for transparent encryption of block devices using\.
+.RE
+.PP
+
+\fButil\-linux\fR
+.RS 4
+Miscellaneous system utilities for Linux, required for \fBlosetup\fR and \fBmkfs\fR\.
+.RE
+.PP
+
+.IP "" 0
+.
+.SH "Usage"
+.
+\fBcryptobox\fR
+.RS 4
+Displays the list of commands
+.RE
+.PP
+
+\fBcryptobox c filename\.img filesystem size\-in\-mb\fR
+.RS 4
+Creates an image file with a given filesystem and size in megabytes\. (eg: \fBcryptobox c myimg\.img ext4 128\fR)
+.RE
+.PP
+
+\fBcryptobox m filename\.img /mount/point\fR
+.RS 4
+Mounts a given image file on a given directory\. (eg: \fBcryptobox m myimg\.img /mnt/cryptoimg\fR)
+.RE
+.PP
+
+\fBcryptobox u /mount/point\fR
+.RS 4
+Unmounts an image file from a given directory\. (eg: \fBcryptobox u /mnt/cryptoimg\fR)
+.RE
+.PP
+
+.SH "Credits"
+Written by Kevin MacMartin: GitHub Projects \fIhttps://github\.com/prurigro?tab=repositories\fR | Arch Linux AUR Packages \fIhttps://aur\.archlinux\.org/packages/?SeB=m&K=prurigro\fR
+.
+.SH "License"
+This script is open source and licensed under the GPLv3 \fIhttp://www\.gnu\.org/copyleft/gpl\.html\fR\.