summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrleek2019-07-25 20:01:10 -0400
committerrleek2019-07-25 20:01:10 -0400
commit5745a7567476fd4fa65b3038c38a21120508c48c (patch)
tree3cd1ef6d1ea557d5b9c8d21e954416efc29248f0
downloadaur-5745a7567476fd4fa65b3038c38a21120508c48c.tar.gz
Created package for installing cryptocoins icon font
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
-rw-r--r--cryptocoins-git.install17
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d18198b055ec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = cryptocoins-git
+ pkgdesc = Cryptocoins is the most complete vector/webfont icon pack of your favourite cryptocurrencies
+ pkgver = da791cf
+ pkgrel = 1
+ url = https://github.com/allienworks/cryptocoins
+ install = cryptocoins-git.install
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = cryptocoins::git+https://github.com/AllienWorks/cryptocoins
+ md5sums = SKIP
+
+pkgname = cryptocoins-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0af980d33155
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Richard Leek <richard@richardleek.com>
+_pkgname=cryptocoins
+pkgname=cryptocoins-git
+pkgver=da791cf
+pkgrel=1
+pkgdesc="Cryptocoins is the most complete vector/webfont icon pack of your favourite cryptocurrencies"
+arch=(any)
+makedepends=('git')
+depends=(fontconfig xorg-font-utils)
+url="https://github.com/allienworks/cryptocoins"
+license=('MIT')
+source=("${_pkgname}::git+https://github.com/AllienWorks/cryptocoins")
+install=$pkgname.install
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/$_pkgname"
+ install -D -m644 webfont/cryptocoins.ttf "${pkgdir}/usr/share/fonts/misc/cryptocoins.ttf"
+ install -D -m755 LICENCE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
diff --git a/cryptocoins-git.install b/cryptocoins-git.install
new file mode 100644
index 000000000000..42df5cface83
--- /dev/null
+++ b/cryptocoins-git.install
@@ -0,0 +1,17 @@
+post_install() {
+ echo -n "Updating font cache."
+ mkfontscale /usr/share/fonts/misc
+ mkfontdir /usr/share/fonts/misc
+ xset +fp /usr/share/fonts/misc
+ xset fp rehash
+ fc-cache -f
+ echo "Finished updating font cache."
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}