summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Stenzel2020-04-17 11:53:41 +0200
committerSebastian Stenzel2020-04-17 11:53:41 +0200
commit9f999d8238b32ff7e98f81f2440753fea9d2634f (patch)
tree487433738cf851a851fbea9777a11bf38dcd358c
parent53350fec42bcf94072d82a97dff004de97a64560 (diff)
downloadaur-9f999d8238b32ff7e98f81f2440753fea9d2634f.tar.gz
Update to 1.5.0
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD19
-rw-r--r--cryptomator.pngbin45179 -> 0 bytes
-rw-r--r--org.cryptomator.Cryptomator.desktop (renamed from cryptomator.desktop)5
-rw-r--r--org.cryptomator.Cryptomator.pngbin0 -> 23272 bytes
-rw-r--r--org.cryptomator.Cryptomator.svg1
6 files changed, 24 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 27145758b90c..6e062cf3f05a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,21 @@
pkgbase = cryptomator
pkgdesc = Multiplatform transparent client-side encryption of your files in the cloud.
- pkgver = 1.4.15
+ pkgver = 1.5.0
pkgrel = 1
url = https://cryptomator.org/
arch = x86_64
license = GPL3
depends = fuse2
options = !strip
- source = cryptomator-1.4.15-x86_64.AppImage::https://dl.bintray.com/cryptomator/cryptomator/1.4.15/cryptomator-1.4.15-x86_64.AppImage
- source = cryptomator.desktop
- source = cryptomator.png
+ source = cryptomator-1.5.0-x86_64.AppImage::https://dl.bintray.com/cryptomator/cryptomator/1.5.0/cryptomator-1.5.0-x86_64.AppImage
+ source = org.cryptomator.Cryptomator.desktop
+ source = org.cryptomator.Cryptomator.png
+ source = org.cryptomator.Cryptomator.svg
source = cryptomator-vault.xml
- sha256sums = 9d52051abc07727e2b6868e70347910d41347147078213e3ea846d26d113c047
- sha256sums = 5f82b1846e5db21fcca2fb914321eecbc9906c8580ef4318d6a12c011e1e3285
- sha256sums = fb1213c07d01c86757744507a151b37d4e917b69965a7db6d28bd99fcc735e6b
+ sha256sums = ce66aabcfc86d59069f1234612b25007904c21cf6c666b932186ee5ccea04baa
+ sha256sums = 53c509fe54ef1c5c28b469d86291536649367fb2030b2c0fb3101da2031f8e6e
+ sha256sums = d299636d78d093117fa7a26563f22e01cdb75b1fcc6cc279bc88627574c968bd
+ sha256sums = 0989ecc24ecd672c5c525ab6f1f0fb18a9eeca86ebec19738f512801c152f756
sha256sums = 78537ead26dcc1488d7fff02f47fce559f70f9bb2d7fa7fa1741ad3cd151bfad
pkgname = cryptomator
diff --git a/PKGBUILD b/PKGBUILD
index e3f063dfc6ab..498d17e8e787 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Sebastian Stenzel <sebastian.stenzel@gmail.com>
pkgname=cryptomator
-pkgver=1.4.15
+pkgver=1.5.0
pkgrel=1
pkgdesc="Multiplatform transparent client-side encryption of your files in the cloud."
arch=('x86_64')
@@ -11,20 +11,23 @@ url="https://cryptomator.org/"
license=('GPL3')
depends=('fuse2')
source=("cryptomator-${pkgver}-x86_64.AppImage::https://dl.bintray.com/cryptomator/cryptomator/${pkgver}/cryptomator-${pkgver}-x86_64.AppImage"
- 'cryptomator.desktop'
- 'cryptomator.png'
+ 'org.cryptomator.Cryptomator.desktop'
+ 'org.cryptomator.Cryptomator.png'
+ 'org.cryptomator.Cryptomator.svg'
'cryptomator-vault.xml')
-sha256sums=('9d52051abc07727e2b6868e70347910d41347147078213e3ea846d26d113c047'
- '5f82b1846e5db21fcca2fb914321eecbc9906c8580ef4318d6a12c011e1e3285'
- 'fb1213c07d01c86757744507a151b37d4e917b69965a7db6d28bd99fcc735e6b'
+sha256sums=('ce66aabcfc86d59069f1234612b25007904c21cf6c666b932186ee5ccea04baa'
+ '53c509fe54ef1c5c28b469d86291536649367fb2030b2c0fb3101da2031f8e6e'
+ 'd299636d78d093117fa7a26563f22e01cdb75b1fcc6cc279bc88627574c968bd'
+ '0989ecc24ecd672c5c525ab6f1f0fb18a9eeca86ebec19738f512801c152f756'
'78537ead26dcc1488d7fff02f47fce559f70f9bb2d7fa7fa1741ad3cd151bfad')
options=('!strip')
package() {
install -Dm755 "${srcdir}/cryptomator-${pkgver}-x86_64.AppImage" "${pkgdir}/opt/cryptomator/cryptomator-${pkgver}-x86_64.AppImage"
install -Dm644 "${srcdir}/cryptomator-vault.xml" "${pkgdir}/usr/share/mime/packages/cryptomator-vault.xml"
- install -Dm644 "${srcdir}/cryptomator.desktop" "${pkgdir}/usr/share/applications/cryptomator.desktop"
- install -Dm644 "${srcdir}/cryptomator.png" "${pkgdir}/opt/cryptomator/cryptomator.png"
+ install -Dm644 "${srcdir}/org.cryptomator.Cryptomator.desktop" "${pkgdir}/usr/share/applications/org.cryptomator.Cryptomator.desktop"
+ install -Dm644 "${srcdir}/org.cryptomator.Cryptomator.png" "${pkgdir}/usr/share/icons/hicolor/scalable/apps/org.cryptomator.Cryptomator.png"
+ install -Dm644 "${srcdir}/org.cryptomator.Cryptomator.svg" "${pkgdir}/usr/share/icons/hicolor/512x512/apps/org.cryptomator.Cryptomator.svg"
mkdir -p "${pkgdir}/usr/bin/"
ln -s "/opt/cryptomator/cryptomator-${pkgver}-x86_64.AppImage" "${pkgdir}/usr/bin/cryptomator"
}
diff --git a/cryptomator.png b/cryptomator.png
deleted file mode 100644
index 1e0832c42af7..000000000000
--- a/cryptomator.png
+++ /dev/null
Binary files differ
diff --git a/cryptomator.desktop b/org.cryptomator.Cryptomator.desktop
index cc74bb5dbc14..0af929141476 100644
--- a/cryptomator.desktop
+++ b/org.cryptomator.Cryptomator.desktop
@@ -2,8 +2,9 @@
Name=Cryptomator
Comment=Cloud Storage Encryption Utility
Exec=/usr/bin/cryptomator
-Icon=/opt/cryptomator/cryptomator.png
+Icon=org.cryptomator.Cryptomator
Terminal=false
Type=Application
-Categories=Utility
+Categories=Utility;Security;FileTools;
MimeType=application/x-vnd.cryptomator-vault-metadata
+StartupWMClass=org-cryptomator-launcher-Cryptomator
diff --git a/org.cryptomator.Cryptomator.png b/org.cryptomator.Cryptomator.png
new file mode 100644
index 000000000000..9c863511181b
--- /dev/null
+++ b/org.cryptomator.Cryptomator.png
Binary files differ
diff --git a/org.cryptomator.Cryptomator.svg b/org.cryptomator.Cryptomator.svg
new file mode 100644
index 000000000000..19d80d49c4c3
--- /dev/null
+++ b/org.cryptomator.Cryptomator.svg
@@ -0,0 +1 @@
+<svg width="1110" height="1110" viewBox="0 0 1108.12 940.2" preserveAspectRatio="xMidYMid meet" xmlns="http://www.w3.org/2000/svg"><path d="m552.69 0c-169.1 0-262.45 143.46-262.45 283.52h524.9c0-140.06-105.33-283.52-262.45-283.52z" fill="#cfcfcf"/><path d="m552.69 53.2c-137.37 0-213.21 116.54-213.21 230.32l213.21 24.18 213.21-24.18c0-113.78-85.57-230.32-213.21-230.32z" fill="#585e62"/><path d="m89.8 739.52a20 20 0 0 1 -2.23-39.88 42.8 42.8 0 1 0 -42.22-21.82 20 20 0 0 1 -35 19.31 82.79 82.79 0 1 1 81.76 42.26 21.78 21.78 0 0 1 -2.31.13z" fill="#585e62"/><rect fill="#cfcfcf" height="144.19" rx="49.42" transform="matrix(.8902923 .45538953 -.45538953 .8902923 261.57 -5.69)" width="104.68" x="90.27" y="467.98"/><path d="m149.47 401.27h62.8a0 0 0 0 1 0 0v94.55a31.4 31.4 0 0 1 -31.4 31.4 31.4 31.4 0 0 1 -31.4-31.4v-94.55a0 0 0 0 1 0 0z" fill="#585e62" transform="matrix(.8902923 .45538953 -.45538953 .8902923 231.23 -31.44)"/><circle cx="222.59" cy="387.53" fill="#cfcfcf" r="75.05"/><path d="m258.09 321.8a75.09 75.09 0 0 0 -91.23 14.64 75.06 75.06 0 0 1 51.58 126.06 75.06 75.06 0 0 0 39.65-140.7z" fill="#b1b1b1"/><path d="m1018.31 739.52a22.09 22.09 0 0 1 -2.28-.13 82.8 82.8 0 1 1 81.77-42.26 20 20 0 1 1 -35-19.31 42.8 42.8 0 1 0 -42.23 21.82 20 20 0 0 1 -2.23 39.88z" fill="#585e62"/><rect fill="#cfcfcf" height="144.19" rx="49.42" transform="matrix(-.8902923 .45538953 -.45538953 -.8902923 2071.05 581.27)" width="104.68" x="913.18" y="467.98"/><path d="m927.25 401.27a31.4 31.4 0 0 1 31.4 31.4v94.55a0 0 0 0 1 0 0h-62.8a0 0 0 0 1 0 0v-94.55a31.4 31.4 0 0 1 31.4-31.4z" fill="#585e62" transform="matrix(-.8902923 .45538953 -.45538953 -.8902923 1964.18 455.35)"/><circle cx="885.53" cy="387.53" fill="#cfcfcf" r="75.05"/><path d="m850 321.8a75.08 75.08 0 0 1 91.22 14.64 75.06 75.06 0 0 0 -51.54 126.06 75.05 75.05 0 0 1 -39.68-140.7z" fill="#b1b1b1"/><path d="m248.78 940.2c-36.67 0-67-39.85-75.51-99.15-4.56-31.83-2.26-65.19 6.48-94 9.41-31 25.51-53.59 45.32-63.72a51.72 51.72 0 0 1 23.69-5.84h103.52v262.71z" fill="#585e62"/><path d="m351.43 940.2c-21.26 0-38.85-39.85-43.78-99.15-2.64-31.83-1.31-65.19 3.76-94 5.45-31 14.78-53.59 26.27-63.72 4.39-3.87 9-5.84 13.73-5.84s9.34 2 13.75 5.8l49.7 43.83c17.37 15.32 23.39 64 20.23 102-2.43 29.28-10 52.18-20.19 61.28l-49.69 43.82c-4.44 3.99-9.08 5.98-13.78 5.98z" fill="#585e62"/><path d="m360.57 699 49.65 43.79c11.18 9.9 17.78 47.45 14.78 83.91-2 24.27-7.83 41.95-14.77 48.13l-49.65 43.79c-18.58 16.38-37.79-19.43-42.83-80.07s6-123.1 24.58-139.51c6.15-5.42 12.5-5.04 18.24-.04z" fill="#35393b"/><path d="m850.73 940.2c36.66 0 67-39.85 75.51-99.15 4.56-31.83 2.26-65.19-6.48-94-9.41-31-25.51-53.59-45.32-63.72a51.72 51.72 0 0 0 -23.69-5.84h-103.53v262.71z" fill="#585e62"/><path d="m748.08 940.2c21.26 0 38.85-39.85 43.78-99.15 2.64-31.83 1.31-65.19-3.76-94-5.45-31-14.79-53.59-26.27-63.72-4.4-3.87-9-5.84-13.73-5.84s-9.34 2-13.76 5.8l-49.69 43.83c-17.38 15.32-23.39 64-20.23 102 2.43 29.28 10 52.18 20.19 61.28l49.68 43.82c4.45 3.99 9.09 5.98 13.79 5.98z" fill="#585e62"/><path d="m738.94 699-49.65 43.79c-11.19 9.86-17.8 47.41-14.77 83.87 2 24.27 7.83 41.95 14.77 48.13l49.65 43.79c18.61 16.41 37.78-19.43 42.82-80.07s-6-123.1-24.58-139.51c-6.18-5.38-12.5-5-18.24 0z" fill="#35393b"/><path d="m848.63 451.38a83.62 83.62 0 0 1 -.56-45.6c14.74-53.13 5.06-111.78 5.06-111.78-185.07-57.77-300.13-.48-300.13-.48s-114.79-57.64-300-.45c0 0-9.86 58.64 4.72 111.83a83.69 83.69 0 0 1 -.69 45.59c-5.14 17.57-10.72 44.5-10.77 78.8-.37 249 306 326.08 306 326.08s306.58-76.15 306.95-325.16c0-34.3-5.49-61.21-10.58-78.83z" fill="#cfcfcf"/><path d="m552.34 808.87c-50.72-15.87-261.7-93.25-261.42-279.51 0-29.65 4.89-52.42 9-66.31a128.3 128.3 0 0 0 .91-70c-6.2-22.58-6.9-47.13-6.17-65.29 40.48-10.23 80.2-15.37 118.41-15.32 75.66.12 119.86 21 120.3 21.17l20.39 10.23 19.24-10.32c.11 0 44.36-20.75 120-20.64 38.21.06 77.91 5.32 118.37 15.68.67 18.14-.1 42.71-6.37 65.27a128.33 128.33 0 0 0 .69 70c4 13.91 8.82 36.69 8.77 66.35-.28 187.06-211.26 263.09-262.12 278.69z" fill="#49b04a"/><path d="m610.15 478.76a57.46 57.46 0 1 0 -70.15 55.92l-32.29 135.47 44.67 12.85 44.71-12.71-31.84-135.57a57.46 57.46 0 0 0 44.9-55.96z" fill="#35393b"/><g fill="#49b04a"><path d="m454.94 131.08a60.64 60.64 0 0 0 -60.64 60.64h121.28a60.64 60.64 0 0 0 -60.64-60.64z"/><path d="m642.38 131.08a60.64 60.64 0 0 0 -60.64 60.64h121.26a60.64 60.64 0 0 0 -60.62-60.64z"/><circle cx="483.23" cy="229.43" r="11.52"/><circle cx="528.52" cy="229.43" r="11.52"/><circle cx="573.8" cy="229.43" r="11.52"/><circle cx="619.09" cy="229.43" r="11.52"/></g></svg> \ No newline at end of file