summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Keen2015-06-13 00:26:49 -0400
committerKyle Keen2015-06-13 00:26:49 -0400
commit21ded610191800b426f8c7f37da47fa0594a1cbe (patch)
tree7600d5c944137748d191a4f014c1f03ecdf9c9c0
downloadaur-21ded610191800b426f8c7f37da47fa0594a1cbe.tar.gz
Initial import
-rw-r--r--.AURINFO19
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD40
3 files changed, 79 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..f63130ee877b
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,19 @@
+pkgbase = cryptominisat4
+ pkgdesc = A modern, multi-threaded, feature-rich, simplifying SAT solver
+ pkgver = 4.2.0
+ pkgrel = 1
+ url = http://www.msoos.org/cryptominisat4/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = python2
+ makedepends = boost
+ depends = zlib
+ depends = gcc-libs
+ depends = boost-libs
+ depends = intel-tbb
+ optdepends = python2: python module
+ source = http://msoos.org/largefiles/cryptominisat-4.2.0.tar.bz2
+
+pkgname = cryptominisat4
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8de2d6677438
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = cryptominisat4
+ pkgdesc = A modern, multi-threaded, feature-rich, simplifying SAT solver
+ pkgver = 4.2.0
+ pkgrel = 1
+ url = http://www.msoos.org/cryptominisat4/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = python2
+ makedepends = boost
+ depends = zlib
+ depends = gcc-libs
+ depends = boost-libs
+ depends = intel-tbb
+ optdepends = python2: python module
+ source = http://msoos.org/largefiles/cryptominisat-4.2.0.tar.bz2
+ md5sums = d12ed2839160ad946a3925c8eec94a39
+
+pkgname = cryptominisat4
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..877e57c61efc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Kyle Keen <keenerd@gmail.com>
+
+pkgname=cryptominisat4
+pkgver=4.2.0
+pkgrel=1
+pkgdesc="A modern, multi-threaded, feature-rich, simplifying SAT solver"
+arch=('i686' 'x86_64')
+url="http://www.msoos.org/cryptominisat4/"
+license=('LGPL')
+depends=('zlib' 'gcc-libs' 'boost-libs' 'intel-tbb')
+makedepends=('python2' 'boost')
+optdepends=('python2: python module')
+source=("http://msoos.org/largefiles/cryptominisat-$pkgver.tar.bz2")
+md5sums=('d12ed2839160ad946a3925c8eec94a39')
+
+# many fancy features requiring makedeps
+# intel-tbb, python2, m4ri, libmysqlclient, valgrind
+
+build() {
+ cd cryptominisat4-$pkgver
+ sed -i 's/python$/python2/' python/Makefile
+ mkdir -p build
+ cd build
+ # options to play with:
+ # -DUSE_TBB -DUSE_ZLIB -DUSE_MYSQL
+ # NOMYSQL NOSTATS NOM4RI ENABLE_TESTING
+ cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr \
+ -DNOM4RI=on -DNOMYSQL=on ../
+ make
+}
+
+package() {
+ cd cryptominisat4-$pkgver/build
+ make install DESTDIR="$pkgdir"
+ mv "$pkgdir/usr/bin/cryptominisat" "$pkgdir/usr/bin/cryptominisat4"
+ # todo, tweak the build tools to respect DESTDIR
+ cd py-lib
+ python2 setup.py install --record files.txt --root="${pkgdir}"
+}
+