summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJon Gjengset2015-06-08 16:22:38 -0400
committerJon Gjengset2015-06-08 16:22:38 -0400
commitb61eab5dd04354895a048f36157e9aec343de2ca (patch)
tree05482aed75953c762a53ee646465cec336fb2e5d
downloadaur-b61eab5dd04354895a048f36157e9aec343de2ca.tar.gz
First
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD31
-rw-r--r--cryptsetup-gui.install11
4 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d0f1844937f8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = cryptsetup-gui
+ pkgdesc = Simple GUI for unlocking LUKS encrypted devices
+ pkgver = 0.6.1
+ pkgrel = 1
+ url = https://github.com/jonhoo/cryptsetup-gui
+ install = cryptsetup-gui.install
+ arch = any
+ license = MIT
+ makedepends = gcc
+ makedepends = glib2
+ depends = glib2
+ depends = cryptsetup
+ source = https://github.com/jonhoo/cryptsetup-gui/archive/v0.6.1.tar.gz
+ md5sums = 38044a3b67f488b8f8b9adfea36b50ba
+
+pkgname = cryptsetup-gui
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4f752c559aa4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+src/
+pkg/
+*.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3d80431197a4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Jon Gjengset <jon@thesquareplanet.com>
+pkgname=cryptsetup-gui
+pkgver=0.6.1
+pkgrel=1
+epoch=
+pkgdesc="Simple GUI for unlocking LUKS encrypted devices"
+arch=('any')
+url="https://github.com/jonhoo/cryptsetup-gui"
+license=('MIT')
+groups=()
+depends=('glib2' 'cryptsetup')
+makedepends=('gcc' 'glib2')
+conflicts=()
+replaces=()
+install=$pkgname.install
+changelog=
+source=("https://github.com/jonhoo/$pkgname/archive/v${pkgver}.tar.gz")
+noextract=()
+md5sums=('38044a3b67f488b8f8b9adfea36b50ba')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/cryptsetup-gui.install b/cryptsetup-gui.install
new file mode 100644
index 000000000000..d1c4e193b152
--- /dev/null
+++ b/cryptsetup-gui.install
@@ -0,0 +1,11 @@
+post_install() {
+ echo "To enable decryption on logon, take the following four steps:"
+ echo " 1. Add the noauto option to your entry in /etc/crypttab"
+ echo " 2. Add the noauto flag to your entry in /etc/fstab"
+ echo " 3. cp /etc/skel/.xinitrc-cryptsetup-gui /home/<you>/.xinitrc when /home is unmounted"
+ echo " 4. Alter /home/<you>/.xinitrc and put in the *name* of your crypted partition"
+ echo ""
+ echo "Enjoy!"
+}
+
+# vim:set ts=2 sw=2 et: