diff options
author | semtor | 2023-04-07 21:56:30 +0800 |
---|---|---|
committer | semtor | 2023-04-07 21:56:30 +0800 |
commit | 37415e27c506d47cf9f513119e3c085c31f39bb8 (patch) | |
tree | df3d2b6bb7e30131bb5121a3e253a71552019f57 | |
parent | 975f250cabe51826a92409c617c76c4fa105bdef (diff) | |
download | aur-37415e27c506d47cf9f513119e3c085c31f39bb8.tar.gz |
use cmake instead of xmake
-rw-r--r-- | PKGBUILD | 9 |
1 files changed, 5 insertions, 4 deletions
@@ -1,6 +1,6 @@ #Maintainer: semtor<semtorcc@gmail.com> pkgname=cs -pkgver=0.1.1 +pkgver=0.1.2 pkgrel=1 epoch= pkgdesc="The Ls command with icons implemented in C++" @@ -14,11 +14,12 @@ md5sums=('SKIP') build() { cd "$pkgname-$pkgver" - xmake + mkdir build&&cd build + cmake -DCMAKE_INSTALL_PREFIX=$pkgdir/usr .. } package() { cd "$pkgname-$pkgver" - mkdir $pkgdir/usr/bin -p - cp build/linux/x86_64/release/cs $pkgdir/usr/bin + cd build + make && make install } |