summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsemtor2023-04-07 21:56:30 +0800
committersemtor2023-04-07 21:56:30 +0800
commit37415e27c506d47cf9f513119e3c085c31f39bb8 (patch)
treedf3d2b6bb7e30131bb5121a3e253a71552019f57
parent975f250cabe51826a92409c617c76c4fa105bdef (diff)
downloadaur-37415e27c506d47cf9f513119e3c085c31f39bb8.tar.gz
use cmake instead of xmake
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 240f4aa199cc..15c8fd59ec1a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
#Maintainer: semtor<semtorcc@gmail.com>
pkgname=cs
-pkgver=0.1.1
+pkgver=0.1.2
pkgrel=1
epoch=
pkgdesc="The Ls command with icons implemented in C++"
@@ -14,11 +14,12 @@ md5sums=('SKIP')
build() {
cd "$pkgname-$pkgver"
- xmake
+ mkdir build&&cd build
+ cmake -DCMAKE_INSTALL_PREFIX=$pkgdir/usr ..
}
package() {
cd "$pkgname-$pkgver"
- mkdir $pkgdir/usr/bin -p
- cp build/linux/x86_64/release/cs $pkgdir/usr/bin
+ cd build
+ make && make install
}