summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsemtor2023-04-07 19:24:38 +0800
committersemtor2023-04-07 19:24:38 +0800
commit975f250cabe51826a92409c617c76c4fa105bdef (patch)
treec76a4369906d294836c7aa75b6ad50796eb1f034
downloadaur-975f250cabe51826a92409c617c76c4fa105bdef.tar.gz
modern ls command with icons
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..277a0bbec53c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = cs
+ pkgdesc = The Ls command with icons implemented in C++
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/semtor/cs
+ arch = x86_64
+ license = MIT
+ makedepends = gcc-libs
+ makedepends = glibc
+ makedepends = xmake
+ makedepends = git
+ source = cs-0.1.1::https://github.com/semtor/cs/archive/refs/tags/0.1.1.tar.gz
+ md5sums = SKIP
+
+pkgname = cs
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..240f4aa199cc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+#Maintainer: semtor<semtorcc@gmail.com>
+pkgname=cs
+pkgver=0.1.1
+pkgrel=1
+epoch=
+pkgdesc="The Ls command with icons implemented in C++"
+arch=('x86_64')
+url="https://github.com/semtor/cs"
+license=('MIT')
+makedepends=('gcc-libs' 'glibc' 'xmake' 'git')
+source=("$pkgname-$pkgver::$url/archive/refs/tags/$pkgver.tar.gz")
+#noextract=("${source[@]##*/}")
+md5sums=('SKIP')
+
+build() {
+ cd "$pkgname-$pkgver"
+ xmake
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ mkdir $pkgdir/usr/bin -p
+ cp build/linux/x86_64/release/cs $pkgdir/usr/bin
+}