summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-07-10 16:33:21 +0800
committerzxp198210052023-07-10 16:33:21 +0800
commit51ba39f877ac142986582eecfdd5aea5c8b16c73 (patch)
treee698a0bed249585f50fb7a991073a1ee56303897
parente6ea5ecd1c8d7cddca1bcefef83b822007f49254 (diff)
downloadaur-51ba39f877ac142986582eecfdd5aea5c8b16c73.tar.gz
first release
-rw-r--r--.SRCINFO37
-rw-r--r--PKGBUILD24
-rw-r--r--csbooks.sh7
3 files changed, 28 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 794c646bab40..6bffd8d0c8df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,40 +1,17 @@
pkgbase = csbooks-bin
- pkgdesc = csBooks is the best epub reader, pdf reader, mobi book reader and djvu reader
+ pkgdesc = A smart book management and reading software,also a PDF reader, EPUB reader, MOBI reader and DJVU file reader.
pkgver = 7.5.0
- pkgrel = 4
+ pkgrel = 1
url = https://caesiumstudio.com/csbooks/
arch = x86_64
- license = unknown
- depends = alsa-lib
- depends = gtk3
- depends = nss
- depends = at-spi2-core
- depends = libdrm
- depends = glib2
- depends = dbus
- depends = gdk-pixbuf2
- depends = libxrandr
- depends = libxdamage
+ license = custom
+ depends = electron
depends = hicolor-icon-theme
- depends = libxshmfence
- depends = gcc-libs
- depends = libxcomposite
- depends = libxcb
- depends = cairo
- depends = libxext
- depends = mesa
- depends = expat
- depends = libcups
- depends = nspr
- depends = libx11
- depends = libxfixes
- depends = pango
- depends = glibc
- depends = libxkbcommon
- conflicts = csbooks-appimage
+ provides = csbooks
conflicts = csbooks
source = csbooks-bin-7.5.0.pacman::https://github.com/caesiumstudio/csBooks-updates/releases/download/latest/csBooks-7.5.0.pacman
+ source = csbooks.sh
sha256sums = b1dfc2d6b137580b7bba60da5d97886369170f6b38b3154ad919847b9eca7afc
- sha256sums = 9e45f7627b17b6f7dbfa93c96c98c88e90405629835ffaf3c3acab2243f2ef64
+ sha256sums = c280898ec6cb9239dc64a9e7b1fc2b2e8afc6b36078e5f4001bc4fc820e57a9e
pkgname = csbooks-bin
diff --git a/PKGBUILD b/PKGBUILD
index 678b322f3e8d..7716a7c7edd6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,23 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname="csbooks-bin"
pkgver=7.5.0
-pkgrel=4
-pkgdesc="csBooks is the best epub reader, pdf reader, mobi book reader and djvu reader"
+pkgrel=1
+pkgdesc="A smart book management and reading software,also a PDF reader, EPUB reader, MOBI reader and DJVU file reader."
arch=('x86_64')
url="https://caesiumstudio.com/csbooks/"
_githuburl="https://github.com/caesiumstudio/csBooks-updates"
-license=('unknown')
-conflicts=("${pkgname%-bin}-appimage" "${pkgname%-bin}")
-depends=('alsa-lib' 'gtk3' 'nss' 'at-spi2-core' 'libdrm' 'glib2' 'dbus' 'gdk-pixbuf2' 'libxrandr' \
- 'libxdamage' 'hicolor-icon-theme' 'libxshmfence' 'gcc-libs' 'libxcomposite' 'libxcb' 'cairo' \
- 'libxext' 'mesa' 'expat' 'libcups' 'nspr' 'libx11' 'libxfixes' 'pango' 'glibc' 'libxkbcommon')
-source=("${pkgname}-${pkgver}.pacman::${_githuburl}/releases/download/latest/csBooks-${pkgver}.pacman")
+license=('custom')
+conflicts=("${pkgname%-bin}")
+provides=("${pkgname%-bin}")
+depends=('electron' 'hicolor-icon-theme')
+source=("${pkgname}-${pkgver}.pacman::${_githuburl}/releases/download/latest/csBooks-${pkgver}.pacman"
+ "${pkgname%-bin}.sh")
sha256sums=('b1dfc2d6b137580b7bba60da5d97886369170f6b38b3154ad919847b9eca7afc'
- '9e45f7627b17b6f7dbfa93c96c98c88e90405629835ffaf3c3acab2243f2ef64')
+ 'c280898ec6cb9239dc64a9e7b1fc2b2e8afc6b36078e5f4001bc4fc820e57a9e')
package() {
- cp --parents -a {opt,usr} "${pkgdir}"
+ install -Dm644 "${srcdir}/opt/csBooks/resources/app.asar" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}.asar"
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}"
+ sed "s|Exec=/opt/csBooks/${pkgname%-bin} %U|Exec=/opt/${pkgname%-bin}/${pkgname%-bin}|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
+ cp -r "${srcdir}/usr" "${pkgdir}"
+ install -Dm644 "${srcdir}/opt/csBooks/LICENSE"* -t "${pkgdir}/usr/share/licenses/${pkgname}"
} \ No newline at end of file
diff --git a/csbooks.sh b/csbooks.sh
new file mode 100644
index 000000000000..8d711ec46c0a
--- /dev/null
+++ b/csbooks.sh
@@ -0,0 +1,7 @@
+
+#!/bin/bash
+if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
+ exec electron /opt/csbooks/csbooks.asar "$@"
+else
+ exec electron --no-sandbox /opt/csbooks/csbooks.asar "$@"
+fi \ No newline at end of file