summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-02-21 16:47:57 +0800
committerzxp198210052023-02-21 16:47:57 +0800
commit6044029ec4173a9b49379ffcbca7078499175c7c (patch)
tree6c083bafcaf32e8107bc3932397a3e8ae96ec9fd
downloadaur-6044029ec4173a9b49379ffcbca7078499175c7c.tar.gz
the first release
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD46
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ae6626699d0f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = csbooks-bin
+ pkgdesc = csBooks is the best epub reader, pdf reader, mobi book reader and djvu reader for windows, linux and mac os. It solves your problems if you need ebook manager, library manager on linux, best comic book reader, cbz file reader, cbr file reader etc.
+ pkgver = 7.5.0
+ pkgrel = 1
+ url = https://caesiumstudio.com/csbooks/
+ arch = x86_64
+ license = custom
+ depends = alsa-lib
+ depends = gtk3
+ depends = nss
+ depends = at-spi2-core
+ conflicts = csbooks
+ conflicts = csbooks-appimage
+ source = csbooks-7.5.0.pacman::https://github.com/caesiumstudio/csBooks-updates/releases/download/latest/csBooks-7.5.0.pacman
+ sha512sums = 59d1aa3fe1b242eed38470c23ecd90855ce4077ae94b5bd2584654c3287c451834b4c449966604bd26871593b8fb2d7809d103ef967e09e0b1ed74cffb825d74
+
+pkgname = csbooks-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..50bc3794ffe3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname=csbooks-bin
+_pkgname=csbooks
+pkgver=7.5.0
+pkgrel=1
+pkgdesc="csBooks is the best epub reader, pdf reader, mobi book reader and djvu reader for windows, linux and mac os.
+ It solves your problems if you need ebook manager, library manager on linux, best comic book reader, cbz file reader, cbr file reader etc."
+arch=('x86_64')
+url="https://caesiumstudio.com/csbooks/"
+_githuburl="https://github.com/caesiumstudio/csBooks-updates"
+license=('custom')
+conflicts=(
+ 'csbooks'
+ 'csbooks-appimage'
+ )
+depends=(
+ 'alsa-lib'
+ 'gtk3'
+ 'nss'
+ 'at-spi2-core'
+)
+options=()
+source=(
+ "${_pkgname}-${pkgver}.pacman::${_githuburl}/releases/download/latest/csBooks-${pkgver}.pacman"
+)
+sha512sums=('59d1aa3fe1b242eed38470c23ecd90855ce4077ae94b5bd2584654c3287c451834b4c449966604bd26871593b8fb2d7809d103ef967e09e0b1ed74cffb825d74')
+
+prepare() {
+ mv "${srcdir}/opt/csBooks" "${srcdir}/opt/${pkgname}"
+ mv "${srcdir}/usr/share/applications/${_pkgname}.desktop" "${srcdir}/usr/share/applications/${pkgname}.desktop"
+ sed 's/Exec=\/opt\/csBooks\/csbooks/Exec=\/opt\/csbooks-bin\/csbooks/g;s/Icon=csbooks/Icon=csbooks-bin/g' \
+ -i "${srcdir}/usr/share/applications/${pkgname}.desktop"
+ for i in 16x16 24x24 32x32 48x48 64x64 96x96 128x128 256x256 512x512 1024x1024; do
+ mv "${srcdir}/usr/share/icons/hicolor/${i}/apps/${_pkgname}.png" \
+ "${srcdir}/usr/share/icons/hicolor/${i}/apps/${pkgname}.png"
+ done
+}
+
+package() {
+ cp --parents -a {opt,usr} "${pkgdir}"
+ for i in 16x16 24x24 32x32 48x48 64x64 96x96 128x128 256x256 512x512 1024x1024; do
+ install -Dm644 "${srcdir}/usr/share/icons/hicolor/${i}/apps/${pkgname}.png" \
+ "${pkgdir}/usr/share/icons/hicolor/${i}/apps/${pkgname}.png"
+ done
+ install -Dm644 "${srcdir}/usr/share/applications/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+}