summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-02-29 17:43:31 +0800
committerzxp198210052024-02-29 17:43:31 +0800
commitdc2d660b4087eaecfef144ce3567c92c0b448348 (patch)
tree03290ea13ba23fa0f324e7374d6a22cd0f2bb6a5
parent6d87c1d9d0b89e729026e8345ca22e25653ae387 (diff)
downloadaur-dc2d660b4087eaecfef144ce3567c92c0b448348.tar.gz
fix errors
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--csbooks.sh7
3 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 87ae19e435e5..ff1bf1ff5802 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = csbooks-bin
pkgdesc = A smart book management and reading software,also a PDF reader, EPUB reader, MOBI reader and DJVU file reader.
pkgver = 7.5.0
- pkgrel = 7
+ pkgrel = 8
url = https://caesiumstudio.com/csbooks/
arch = x86_64
- license = custom
+ license = LicenseRef-custom
depends = electron21
depends = hicolor-icon-theme
provides = csbooks=7.5.0
@@ -14,6 +14,6 @@ pkgbase = csbooks-bin
source = csbooks.sh
sha256sums = b1dfc2d6b137580b7bba60da5d97886369170f6b38b3154ad919847b9eca7afc
sha256sums = e3b3003f395da5789a53b25e32f44d649524de7aad73cb79a1f48694f93ae8d5
- sha256sums = 1d3f21d54a2d9d1a53661bd91c2afd00df79b0ce4057a66b4c953febfc464cd8
+ sha256sums = f80acf84a87f3f50d7c4e2ed22f4d0e8b09dd98a6c26253f2524e5413771eab1
pkgname = csbooks-bin
diff --git a/PKGBUILD b/PKGBUILD
index 35e49bcc7b87..3d76db1be44a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@ pkgname=csbooks-bin
_pkgname=csBooks
pkgver=7.5.0
_electronversion=21
-pkgrel=7
+pkgrel=8
pkgdesc="A smart book management and reading software,also a PDF reader, EPUB reader, MOBI reader and DJVU file reader."
arch=('x86_64')
url="https://caesiumstudio.com/csbooks/"
_ghurl="https://github.com/caesiumstudio/csBooks-updates"
-license=('custom')
+license=('LicenseRef-custom')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
@@ -22,11 +22,11 @@ source=(
)
sha256sums=('b1dfc2d6b137580b7bba60da5d97886369170f6b38b3154ad919847b9eca7afc'
'e3b3003f395da5789a53b25e32f44d649524de7aad73cb79a1f48694f93ae8d5'
- '1d3f21d54a2d9d1a53661bd91c2afd00df79b0ce4057a66b4c953febfc464cd8')
+ 'f80acf84a87f3f50d7c4e2ed22f4d0e8b09dd98a6c26253f2524e5413771eab1')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
- -e "s|@appasar@|app.asar|g" \
+ -e "s|@runname@|app.asar|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
sed "s|/opt/${_pkgname}/${pkgname%-bin}|${pkgname%-bin}|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
}
diff --git a/csbooks.sh b/csbooks.sh
index 0d20cddc70ca..e6784b369c25 100644
--- a/csbooks.sh
+++ b/csbooks.sh
@@ -1,14 +1,15 @@
#!/bin/sh
set -e
_APPDIR="/usr/lib/@appname@"
-_ASAR="${_APPDIR}/@appasar@"
+_RUNNAME="${_APPDIR}/@runname@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
+export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_ASAR}" "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
else
- exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file