summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortaotieren2021-07-29 11:16:01 +0800
committertaotieren2021-07-29 11:16:01 +0800
commite4b5605b34db24c2b52d54387888f08ef4d0648e (patch)
tree45ca824b202af3204b6fa0f0d3b27dd92ea604f9
parentf1b8df98c0593840f506714bd0103bc08127261a (diff)
downloadaur-e4b5605b34db24c2b52d54387888f08ef4d0648e.tar.gz
Update PKGBUILD
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD30
2 files changed, 17 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8fde351ba81f..6623fd6fd365 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,8 +9,10 @@ pkgbase = csky-debugserver-bin
depends = bash
options = !strip
source = csky-debugserver-bin-5.12.1.tar.gz::https://occ-oss-prod.oss-cn-hangzhou.aliyuncs.com/resource/1836682/1626764200205/T-Head-DebugServer-linux-x86_64-V5.12.1-20210716.sh.tar.gz
- source = https://occ-oss-prod.oss-cn-hangzhou.aliyuncs.com/resource/1355977/1588909480730/C-Sky+Debugger+Server+User+Guide_v5.10.pdf
+ source = DebugServer User Guide_v5.10.pdf::https://occ-oss-prod.oss-cn-hangzhou.aliyuncs.com/resource/1355977/1588909480730/C-Sky+Debugger+Server+User+Guide_v5.10.pdf
+ source = DebugServer User Guide v5.6.pdf::https://occ-oss-prod.oss-cn-hangzhou.aliyuncs.com/resource/1355977/1588916696490/C-Sky+Debugger+Server+User+Guide+v5.6.pdf
sha256sums = 054dd396aaf13adf409e31e2ad64e408843f27b892ed5175625bc1a3c781ff75
sha256sums = 6a004189c409a66f550c676990c637b08cbad5f928fed6e0309caf95fe1e62c2
+ sha256sums = 6a004189c409a66f550c676990c637b08cbad5f928fed6e0309caf95fe1e62c2
pkgname = csky-debugserver-bin
diff --git a/PKGBUILD b/PKGBUILD
index 8f8c57220e45..6da6aed00f84 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,6 @@
pkgname=csky-debugserver-bin
pkgver=5.12.1
-_pkgver=V${pkgver}-20210716
pkgrel=2
epoch=
pkgdesc="C-Sky Debugger Server"
@@ -21,35 +20,34 @@ backup=()
options=('!strip')
install=
changelog=
-source=("${pkgname}-${pkgver}.tar.gz::https://occ-oss-prod.oss-cn-hangzhou.aliyuncs.com/resource/1836682/1626764200205/T-Head-DebugServer-linux-${arch}-${_pkgver}.sh.tar.gz"
- "https://occ-oss-prod.oss-cn-hangzhou.aliyuncs.com/resource/1355977/1588909480730/C-Sky+Debugger+Server+User+Guide_v5.10.pdf")
+source=(
+ "${pkgname}-${pkgver}.tar.gz::https://occ-oss-prod.oss-cn-hangzhou.aliyuncs.com/resource/1836682/1626764200205/T-Head-DebugServer-linux-x86_64-V5.12.1-20210716.sh.tar.gz"
+ "DebugServer User Guide_v5.10.pdf::https://occ-oss-prod.oss-cn-hangzhou.aliyuncs.com/resource/1355977/1588909480730/C-Sky+Debugger+Server+User+Guide_v5.10.pdf"
+ "DebugServer User Guide v5.6.pdf::https://occ-oss-prod.oss-cn-hangzhou.aliyuncs.com/resource/1355977/1588916696490/C-Sky+Debugger+Server+User+Guide+v5.6.pdf")
noextract=()
sha256sums=('054dd396aaf13adf409e31e2ad64e408843f27b892ed5175625bc1a3c781ff75'
+ '6a004189c409a66f550c676990c637b08cbad5f928fed6e0309caf95fe1e62c2'
'6a004189c409a66f550c676990c637b08cbad5f928fed6e0309caf95fe1e62c2')
#validpgpkeys=()
prepare(){
# Decrypt gzexe encrypted shell script
# Origin file 92 Line: tail -n +$LNUM $0 > tmp.tar.gz
- tail -n +282 "${srcdir}/T-Head-DebugServer-linux-${arch}-${_pkgver}.sh" > "${srcdir}/${pkgname}-${pkgver}.gz"
-}
-
-build(){
-# Extract the installation file
- tar -xf "${srcdir}/${pkgname}-${pkgver}.gz"
+ tail -n +282 "${srcdir}"/*.sh > "${srcdir}/${pkgname}-${pkgver}.gz"
}
package() {
- install -dm0755 "${pkgdir}/opt/t-head"
- cp -r "${srcdir}/T-HEAD_DebugServer" "${pkgdir}/opt/t-head"
- cp -r "${srcdir}/C-Sky+Debugger+Server+User+Guide_v5.10.pdf" "${pkgdir}/opt/t-head/T-HEAD_DebugServer"
+ install -dm0755 "${pkgdir}/opt/t-head/${pkgname%-bin}"
+ tar -xf "${srcdir}/${pkgname}-${pkgver}.gz" --no-same-owner --no-same-permissions --strip-components=1 -C "${pkgdir}/opt/t-head/${pkgname%-bin}"
+ cp -r "${srcdir}"/*.pdf "${pkgdir}/opt/t-head/${pkgname%-bin}"
- echo "/opt/t-head/T-HEAD_DebugServer" > csky-debug.conf
+ install -Dm0644 /dev/stdin "${pkgdir}/etc/ld.so.conf.d/${pkgname%-bin}.conf" << EOF
+/opt/t-head/${pkgname%-bin}
+EOF
- install -Dm0644 "${srcdir}/csky-debug.conf" "${pkgdir}/etc/ld.so.conf.d/csky-debug.conf"
install -Dm0755 /dev/stdin "${pkgdir}/usr/bin/${pkgname%-bin}" << EOF
#!/bin/env bash
-export PATH=/opt/t-head/C-Sky_DebugServer:\$PATH
-DebugServerConsole.elf \$@
+export PATH=/opt/t-head/${pkgname%-bin}:\$PATH
+DebugServerConsole.elf "\$@"
EOF
}