summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAinola2015-12-28 06:22:15 -0700
committerAinola2015-12-28 06:22:15 -0700
commitdb8a23c8f6abe7a38e22517a657a1824e11d5517 (patch)
tree743c02c7a91793ca48a14a80de8c1635b54babbe
parente2512ed8d7576c44d84e47141db618109e287c0f (diff)
downloadaur-db8a23c8f6abe7a38e22517a657a1824e11d5517.tar.gz
upgpkg: 6.06.0, incorporate patch to prevent boost naming conflicts, temp use of sourceforge
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
-rw-r--r--boost-1.60-name-clash.patch15
-rw-r--r--libm.patch47
4 files changed, 36 insertions, 61 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e83094951eb..247e5465cb6c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Mon Dec 28 13:21:16 UTC 2015
pkgbase = csound
pkgdesc = A programming language for sound rendering and signal processing.
- pkgver = 6.05.0
- pkgrel = 3
+ pkgver = 6.06.0
+ pkgrel = 1
url = http://csound.github.io
arch = i686
arch = x86_64
@@ -29,13 +31,13 @@ pkgbase = csound
optdepends = vim-csound: Syntax Highlighting and Bindings for Vim
optdepends = java-environment: Java Wrapper
optdepends = csound-doc: The Canonical Csound Reference Manual
- source = https://github.com/csound/csound/archive/6.05.0.tar.gz
+ source = http://sourceforge.net/projects/csound/files/csound6/Csound6.06/Csound6.06.tar.gz/download
source = Custom.cmake
- source = libm.patch
+ source = boost-1.60-name-clash.patch
source = csound.sh
- sha256sums = 2384cbc82fe37b70192c87977b52c55b336731ecbfd3be1d8d30c7223815d7b9
+ sha256sums = 03e6542d60eaffc9b4c5e81f36243e8872dedbe94c036adaa8e07c27938feb11
sha256sums = 81c9473ad3142c658afe2e509f3ae597b5349bba07f95d4ba03f420188786e57
- sha256sums = e5f4ac9885225013b6e1f08b85205cb5b32ced518be39004f398be8c9fe69ab9
+ sha256sums = 65a205a8d617b6243a892cea9d2c6ed8ab0ace42a9992615c6274d0adb9187bd
sha256sums = 23db5bda78f13d5f16eceea085bba660d7b7012a89518e477d12dfef82dbadeb
pkgname = csound
diff --git a/PKGBUILD b/PKGBUILD
index 73c06cd90812..4f1648c8373b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: Bernardo Barros
pkgname=csound
-pkgver=6.05.0
-pkgrel=3
+pkgver=6.06.0
+pkgrel=1
pkgdesc="A programming language for sound rendering and signal processing."
arch=('i686' 'x86_64')
url="http://csound.github.io"
@@ -15,19 +15,24 @@ optdepends=('csoundqt: Qt frontend'
'vim-csound: Syntax Highlighting and Bindings for Vim'
'java-environment: Java Wrapper'
'csound-doc: The Canonical Csound Reference Manual')
-source=("https://github.com/csound/csound/archive/${pkgver}.tar.gz"
+source=("http://sourceforge.net/projects/csound/files/csound6/Csound6.06/Csound6.06.tar.gz/download"
"Custom.cmake"
- "libm.patch"
+ "boost-1.60-name-clash.patch"
"csound.sh")
-sha256sums=('2384cbc82fe37b70192c87977b52c55b336731ecbfd3be1d8d30c7223815d7b9'
+sha256sums=('03e6542d60eaffc9b4c5e81f36243e8872dedbe94c036adaa8e07c27938feb11'
'81c9473ad3142c658afe2e509f3ae597b5349bba07f95d4ba03f420188786e57'
- 'e5f4ac9885225013b6e1f08b85205cb5b32ced518be39004f398be8c9fe69ab9'
+ '65a205a8d617b6243a892cea9d2c6ed8ab0ace42a9992615c6274d0adb9187bd'
'23db5bda78f13d5f16eceea085bba660d7b7012a89518e477d12dfef82dbadeb')
prepare() {
+ # Temporarily using SourceForge's copy until Github's version is released.
+ # Moving the folder is easier than editing the PKGBUILD back and forth to rename.
+ mv Csound6.06 "csound-$pkgver"
+
cp "$srcdir"/Custom.cmake "csound-${pkgver}"
- patch -p0 < libm.patch
- cd "csound-${pkgver}"
+
+ # Fixes https://github.com/csound/csound/issues/570 until they release officially.
+ patch -d "$srcdir/csound-$pkgver" -p1 < boost-1.60-name-clash.patch
}
build() {
diff --git a/boost-1.60-name-clash.patch b/boost-1.60-name-clash.patch
new file mode 100644
index 000000000000..7e7dee1580f8
--- /dev/null
+++ b/boost-1.60-name-clash.patch
@@ -0,0 +1,15 @@
+--- Csound6.05/Opcodes/chua/ChuaOscillator.cpp 2015-04-25 14:06:22.995646234 -0500
++++ Csound6.05/Opcodes/chua/ChuaOscillator.cpp 2015-12-21 10:31:58.182362640 -0600
+@@ -117,11 +117,12 @@
+ // d = sys_variables(12);
+ // gnor = a*(x.^3) + b*(x.^2) + c*x + d;
+
+-#include <OpcodeBase.hpp>
+ #include <boost/numeric/ublas/vector.hpp>
+ using namespace boost::numeric;
+ #include <cmath>
+
++#include <OpcodeBase.hpp>
++
+ #undef CS_KSMPS
+ #define CS_KSMPS (opds.insdshead->ksmps)
diff --git a/libm.patch b/libm.patch
deleted file mode 100644
index ef13e2eb8f08..000000000000
--- a/libm.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-diff --git csound-6.05.0/CMake/gLists.txt csound-6.05.0/CMake/gLists.txt
-index 2b16079..18a6ad1 100644
---- csound-6.05.0/CMakeLists.txt
-+++ csound-6.05.0/CMakeLists.txt
-@@ -97,6 +97,10 @@ endfunction(make_executable)
- function(make_utility name srcs)
- make_executable(${name} "${srcs}" "${CSOUNDLIB}")
- add_dependencies(${name} ${CSOUNDLIB})
-+
-+ if(LINUX)
-+ target_link_libraries(${name} m)
-+ endif()
- endfunction()
-
-
-diff --git csound-6.05.0/frontends/CMakeLists.txt csound-6.05.0/frontends/CMakeLists.txt
-index d0e3a21..b31f37a 100644
---- csound-6.05.0/frontends/CMakeLists.txt
-+++ csound-6.05.0/frontends/CMakeLists.txt
-@@ -43,6 +43,9 @@ endfunction(make_plugin_frontend)
-
- # We need a different name to avoid clashes with float libcsound
- make_executable(csound-bin "${CS_MAIN_SRCS}" "${CSOUNDLIB}" csound)
-+if(LINUX)
-+ target_link_libraries(csound-bin m)
-+endif()
-
- message(STATUS "Building csLadspa")
-
-diff --git csound-6.05.0/util/CMakeLists.txt csound-6.05.0/util/CMakeLists.txt
-index 25089cc..ebf0aa5 100644
---- csound-6.05.0/util/CMakeLists.txt
-+++ csound-6.05.0/util/CMakeLists.txt
-@@ -23,9 +23,11 @@ if(BUILD_UTILITIES)
- make_utility(hetro het_main.c)
- make_utility(lpanal lpc_main.c)
- make_utility(lpc_export lpcx_main.c)
-- target_link_libraries(lpc_export m)
- make_utility(lpc_import lpci_main.c)
-- make_executable(mixer-bin mixer_main.c "${CSOUNDLIB}" mixer)
-+ if(LINUX)
-+ make_executable(mixer-bin mixer_main.c "${CSOUNDLIB}" mixer)
-+ endif()
-+ target_link_libraries(mixer-bin m)
- make_utility(pvanal pvc_main.c)
- make_utility(pvlook pvl_main.c)
- make_utility(pv_export pvx_main.c)