summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAinola2015-06-08 11:55:12 -0600
committerAinola2015-06-08 11:55:12 -0600
commitf1b8f72154dc033e9bc807a57749ae0d3ef2b0b8 (patch)
tree51a2895c51c1bb680e623d515fe2171972df6789
downloadaur-f1b8f72154dc033e9bc807a57749ae0d3ef2b0b8.tar.gz
initial
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD39
-rw-r--r--blue.desktop9
-rw-r--r--blue.install12
-rw-r--r--icons.tar.gzbin0 -> 34250 bytes
5 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..803a10b64dcc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = csound-blue
+ pkgdesc = A music composition environment for Csound
+ pkgver = 2.5.14
+ pkgrel = 3
+ url = http://blue.kunstmusik.com/
+ install = blue.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = pd
+ makedepends = scons
+ makedepends = swig
+ makedepends = java-environment>=7
+ makedepends = dssi
+ makedepends = boost
+ depends = csound
+ depends = java-environment>=7
+ provides = csound-blue
+ conflicts = csound-blue
+ options = !strip
+ source = https://downloads.sourceforge.net/project/bluemusic/blue/2.5.x/blue_2.5.14.zip
+ source = blue.desktop
+ source = icons.tar.gz
+ source = blue.install
+ sha256sums = f5af74275e4d6f7cc14230feb010d836691ef6576aee0c7f519c50121fcd04f0
+ sha256sums = 06dcc0dbade0b9c2eb904815aefa86d32e8e21de47fd7cd8873f139c1fb24fe6
+ sha256sums = 60240d02dd3f25b9df684efaf93a5fd05e520b5f46e94f24b58de60604dbae36
+ sha256sums = 1c1bc8b197c31416aa2efb7d6c7af1fb43b0a0fb34b883d6fb92a53da8683114
+
+pkgname = csound-blue
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a3b5c80c18a7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer : Ainola
+# Contributor: Arch Linux Pro Audio <dev@archaudio.org>
+# Contributor: SpepS <dreamspepser at yahoo dot it>
+# Contributor: Bernardo Barros <bernardobarros@gmail.com>
+
+pkgname=csound-blue
+pkgver=2.5.14
+pkgrel=3
+pkgdesc="A music composition environment for Csound"
+arch=(i686 x86_64)
+url="http://blue.kunstmusik.com/"
+license=('GPL')
+depends=('csound' 'java-environment>=7')
+makedepends=('pd' 'scons' 'swig' 'java-environment>=7' 'dssi' 'boost')
+provides=('csound-blue')
+conflicts=('csound-blue')
+source=("https://downloads.sourceforge.net/project/bluemusic/blue/2.5.x/blue_${pkgver}.zip"
+ "blue.desktop"
+ "icons.tar.gz"
+ "blue.install")
+sha256sums=('f5af74275e4d6f7cc14230feb010d836691ef6576aee0c7f519c50121fcd04f0'
+ '06dcc0dbade0b9c2eb904815aefa86d32e8e21de47fd7cd8873f139c1fb24fe6'
+ '60240d02dd3f25b9df684efaf93a5fd05e520b5f46e94f24b58de60604dbae36'
+ '1c1bc8b197c31416aa2efb7d6c7af1fb43b0a0fb34b883d6fb92a53da8683114')
+options=(!strip)
+install=blue.install
+
+package() {
+ mkdir -p "$pkgdir"/opt/blue
+ mkdir -p "$pkgdir"/usr/bin
+ cp -r "$srcdir"/blue/* "$pkgdir"/opt/blue
+ ln -s "/opt/blue/bin/blue" "$pkgdir/usr/bin/blue"
+
+ install -D -m644 "${srcdir}/blue.desktop" "${pkgdir}/usr/share/applications/blue.desktop"
+ for size in 16 22 24 32 48 64 128 256 512; do
+ install -Dm644 "$srcdir/icons/${size}.png" \
+ "${pkgdir}/usr/share/icons/hicolor/${size}x${size}/apps/blue.png"
+ done
+}
diff --git a/blue.desktop b/blue.desktop
new file mode 100644
index 000000000000..d03de183554d
--- /dev/null
+++ b/blue.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Encoding=UTF-8
+Value=1.0
+Type=Application
+Name=Blue
+Comment=A music composition environment for Csound.
+Icon=blue.png
+Exec=blue
+Categories=AudioVideo;
diff --git a/blue.install b/blue.install
new file mode 100644
index 000000000000..295ff6b0896a
--- /dev/null
+++ b/blue.install
@@ -0,0 +1,12 @@
+post_install(){
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade(){
+ post_install
+}
+
+post_remove(){
+ post_install
+}
diff --git a/icons.tar.gz b/icons.tar.gz
new file mode 100644
index 000000000000..8e4663b03a1f
--- /dev/null
+++ b/icons.tar.gz
Binary files differ