summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAinola2015-06-08 11:17:53 -0600
committerAinola2015-06-08 11:17:53 -0600
commitaa7317b887da833cc1650c0424b77448c4da3de4 (patch)
tree93758dbde7b1493a2a3c90e9261ae73c80f320c9
downloadaur-aa7317b887da833cc1650c0424b77448c4da3de4.tar.gz
initial
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fbd5b241a17f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = csound-doc
+ pkgdesc = The Canonical Csound Reference Manual
+ pkgver = 6.05
+ pkgrel = 1
+ url = http://csound.github.io
+ arch = any
+ license = LGPL
+ license = GPL
+ depends = csound
+ source = http://downloads.sourceforge.net/csound/Csound6.05_manual_html.zip
+ sha256sums = 4d9a71a4dc2cee28b7a5d879c3e8d39d98711f813f7b797b9bb6a7c3635235bd
+
+pkgname = csound-doc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..04e88af62483
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer : Ainola
+# Contributor: speps <speps at aur dot archlinux dot org>
+# Contributor: Bernardo Barros <bernardobarros@gmail.com>
+# Contributor: Lars Boettcher lars@newyew.de>
+
+pkgname=csound-doc
+pkgver=6.05
+pkgrel=1
+pkgdesc="The Canonical Csound Reference Manual"
+url="http://csound.github.io"
+arch=('any')
+license=('LGPL' 'GPL')
+depends=('csound')
+source=("http://downloads.sourceforge.net/csound/Csound${pkgver}_manual_html.zip")
+sha256sums=('4d9a71a4dc2cee28b7a5d879c3e8d39d98711f813f7b797b9bb6a7c3635235bd')
+
+package() {
+ # docs
+ install -d "$pkgdir/usr/share/doc/csound-doc/html"
+ cp -a "$srcdir"/html/* "$pkgdir/usr/share/doc/csound-doc/html"
+
+ # permissions
+ find "$pkgdir" -type f -exec chmod 644 {} \;
+}