summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAinola2015-06-08 11:53:04 -0600
committerAinola2015-06-08 11:53:04 -0600
commit9630277a8ac8a2000a134393fee65494e94e33cc (patch)
treef0d192bdff926c478049e4822c09e2b5db05d79e
downloadaur-9630277a8ac8a2000a134393fee65494e94e33cc.tar.gz
initial
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD62
-rw-r--r--csoundqt.desktop8
-rw-r--r--csoundqt.install11
4 files changed, 104 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..68b747927612
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = csoundqt
+ pkgdesc = CsoundQt (formerly qutecsound) is a frontend for Csound featuring a highlighting editor with autocomplete, interactive widgets and integrated help
+ pkgver = 0.9.0
+ pkgrel = 2
+ url = http://qutecsound.sourceforge.net/
+ install = csoundqt.install
+ arch = i686
+ arch = x86_64
+ license = GPLv3
+ depends = csound
+ depends = qt4
+ optdepends = csound-doc: html online manual, opcode lookups and more
+ provides = qutecsound
+ conflicts = qutecsound
+ source = http://sourceforge.net/projects/qutecsound/files/CsoundQt/0.9.0/csoundqt-0.9.0-src.tar.gz
+ source = csoundqt.desktop
+ source = http://www.music.mcgill.ca/~gary/rtmidi/release/rtmidi-2.1.0.tar.gz
+ md5sums = 1c3001e44c95d325720641f5eb7f9d3a
+ md5sums = a352bbc3e071bfc1e4c5d17ffa4827a2
+ md5sums = ea4acc28724bc21fb08b6ad5efbc5c36
+
+pkgname = csoundqt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b0ac41421db5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Maintainer: rtfreedman (rob<d0t>til<d0t>freedman<aT>googlemail<d0t>com
+
+pkgname=csoundqt
+pkgver=0.9.0
+pkgrel=2
+pkgdesc="CsoundQt (formerly qutecsound) is a frontend for Csound featuring a highlighting editor with autocomplete, interactive widgets and integrated help"
+arch=('i686' 'x86_64')
+url="http://qutecsound.sourceforge.net/"
+license=('GPLv3') # GPLv3 or at your option LGPLv2
+depends=('csound' 'qt4' )
+optdepends=('csound-doc: html online manual, opcode lookups and more' )
+#optdepends+=('pythonqt: use of example scripts')
+provides=('qutecsound')
+conflicts=('qutecsound')
+install="csoundqt.install"
+#
+# now uses RtMidi, see: http://qutecsound.sourceforge.net/pages/develop.html
+#
+_rtmidi=rtmidi-2.1.0
+source=("http://sourceforge.net/projects/qutecsound/files/CsoundQt/${pkgver}/csoundqt-${pkgver}-src.tar.gz"
+ csoundqt.desktop
+ "http://www.music.mcgill.ca/~gary/rtmidi/release/${_rtmidi}.tar.gz"
+ )
+md5sums=('1c3001e44c95d325720641f5eb7f9d3a'
+ 'a352bbc3e071bfc1e4c5d17ffa4827a2'
+ 'ea4acc28724bc21fb08b6ad5efbc5c36')
+
+prepare() {
+# tarball doesn't have a root dir, extracting to $srcdir
+# DEFAULT_HTML_DIR "/usr/share/doc/csound-doc/html"
+ sed -e 's@"csdocdir", ""@"csdocdir", DEFAULT_HTML_DIR@' \
+ -e 's@/usr/share/qutecsound/Examples/@/usr/share/csoundqt/Examples/@g' -i src/qutecsound.cpp
+ sed 's@../../csoundqt/src/Scripts@/usr/share/csoundqt/Scripts@' -i src/types.h
+}
+
+
+build() {
+# for csound midi module, remove CONFIG+=rtmidi "RTMIDI_DIR=${_rtmidi}"
+# for PythonQt add CONFIG+=pythonqt
+ qmake-qt4 qcs.pro CONFIG+=rtmidi "RTMIDI_DIR=${_rtmidi}"
+ make
+}
+
+package() {
+# tarball doesn't have a root dir, extracting to $srcdir
+ install -d "$pkgdir"/usr/{bin,share/{applications,csoundqt,doc/csoundqt}}
+
+ install -Dm755 bin/CsoundQt-d-cs6 "$pkgdir"/usr/bin/csoundqt
+# desktop file and icon
+ install -Dm644 "$srcdir"/csoundqt.desktop "$pkgdir"/usr/share/applications
+ #install -Dm644 images/qtcs.png "$pkgdir"/usr/share/icons/hicolor/128x128/apps/csoundqt.png
+ install -Dm644 images/qtcs.svg "$pkgdir"/usr/share/icons/hicolor/scalable/apps/csoundqt.svg
+ install -Dm644 images/qtcs.png "$pkgdir"/usr/share/pixmaps/csoundqt.png
+ install -Dm644 images/* -t "$pkgdir"/usr/share/csoundqt/images
+# docs
+ install -Dm644 doc/*.pdf -t "$pkgdir"/usr/share/doc/csoundqt
+ find examples -type f -print0 | xargs -0 -n1 -i{} install -Dm644 '{}' "$pkgdir"/usr/share/doc/csoundqt/'{}'
+ cd src
+ find Examples -type f -print0 | xargs -0 -n1 -i{} install -Dm644 '{}' "$pkgdir"/usr/share/csoundqt/'{}'
+# pythonqt scripts
+ #find Scripts -type f -print0 | xargs -0 -n1 -i{} install -Dm644 '{}' "$pkgdir"/usr/share/csoundqt/'{}'
+}
diff --git a/csoundqt.desktop b/csoundqt.desktop
new file mode 100644
index 000000000000..2c9572a9c724
--- /dev/null
+++ b/csoundqt.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=CsoundQt
+Comment=Csound Qt signal processing environment/editor
+Exec=csoundqt
+Icon=csoundqt
+Terminal=false
+Type=Application
+Categories=Application;AudioVideo;Audio;
diff --git a/csoundqt.install b/csoundqt.install
new file mode 100644
index 000000000000..e111ef946053
--- /dev/null
+++ b/csoundqt.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}