summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAinola2015-09-06 13:32:35 -0600
committerAinola2015-09-06 13:32:35 -0600
commitb9b0554597adc290db162bbbf1422e4c6a3339b9 (patch)
treecbca1284e5b318c41749b54f647d6023ca8c4cb6
parent9630277a8ac8a2000a134393fee65494e94e33cc (diff)
downloadaur-b9b0554597adc290db162bbbf1422e4c6a3339b9.tar.gz
cleanups, add dep to csound-doc
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD43
-rw-r--r--csoundqt.desktop2
3 files changed, 26 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 68b747927612..961e10489bc5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,21 @@
pkgbase = csoundqt
- pkgdesc = CsoundQt (formerly qutecsound) is a frontend for Csound featuring a highlighting editor with autocomplete, interactive widgets and integrated help
+ pkgdesc = A frontend for Csound featuring a highlighting editor with autocomplete, interactive widgets and integrated help
pkgver = 0.9.0
- pkgrel = 2
+ pkgrel = 3
url = http://qutecsound.sourceforge.net/
install = csoundqt.install
arch = i686
arch = x86_64
- license = GPLv3
+ license = GPL3
depends = csound
depends = qt4
- optdepends = csound-doc: html online manual, opcode lookups and more
- provides = qutecsound
- conflicts = qutecsound
+ depends = csound-doc
source = http://sourceforge.net/projects/qutecsound/files/CsoundQt/0.9.0/csoundqt-0.9.0-src.tar.gz
source = csoundqt.desktop
source = http://www.music.mcgill.ca/~gary/rtmidi/release/rtmidi-2.1.0.tar.gz
- md5sums = 1c3001e44c95d325720641f5eb7f9d3a
- md5sums = a352bbc3e071bfc1e4c5d17ffa4827a2
- md5sums = ea4acc28724bc21fb08b6ad5efbc5c36
+ sha256sums = 873c699091e28064bc25f45a1081d583b42c4927061174f76cd8231ef1394feb
+ sha256sums = 4cc7e3d77ce4daf558568f2633645658f565f71c5e6c9f441fd2ade5dd61b138
+ sha256sums = a0a59226614b878e7c32890cb7c38a6fe48a97082baf4913297d4c3958a9b3ac
pkgname = csoundqt
diff --git a/PKGBUILD b/PKGBUILD
index b0ac41421db5..b3b6bf8ff7fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,22 @@
-# Maintainer: rtfreedman (rob<d0t>til<d0t>freedman<aT>googlemail<d0t>com
+# Maintainer: Ainola
+# Contributor: rtfreedman
pkgname=csoundqt
pkgver=0.9.0
-pkgrel=2
-pkgdesc="CsoundQt (formerly qutecsound) is a frontend for Csound featuring a highlighting editor with autocomplete, interactive widgets and integrated help"
+pkgrel=3
+pkgdesc="A frontend for Csound featuring a highlighting editor with autocomplete, interactive widgets and integrated help"
arch=('i686' 'x86_64')
url="http://qutecsound.sourceforge.net/"
-license=('GPLv3') # GPLv3 or at your option LGPLv2
-depends=('csound' 'qt4' )
-optdepends=('csound-doc: html online manual, opcode lookups and more' )
-#optdepends+=('pythonqt: use of example scripts')
-provides=('qutecsound')
-conflicts=('qutecsound')
+license=('GPL3') # or, at your option, LGPL2
+depends=('csound' 'qt4' 'csound-doc')
install="csoundqt.install"
-#
-# now uses RtMidi, see: http://qutecsound.sourceforge.net/pages/develop.html
-#
_rtmidi=rtmidi-2.1.0
source=("http://sourceforge.net/projects/qutecsound/files/CsoundQt/${pkgver}/csoundqt-${pkgver}-src.tar.gz"
- csoundqt.desktop
- "http://www.music.mcgill.ca/~gary/rtmidi/release/${_rtmidi}.tar.gz"
- )
-md5sums=('1c3001e44c95d325720641f5eb7f9d3a'
- 'a352bbc3e071bfc1e4c5d17ffa4827a2'
- 'ea4acc28724bc21fb08b6ad5efbc5c36')
+ "csoundqt.desktop"
+ "http://www.music.mcgill.ca/~gary/rtmidi/release/${_rtmidi}.tar.gz")
+sha256sums=('873c699091e28064bc25f45a1081d583b42c4927061174f76cd8231ef1394feb'
+ '4cc7e3d77ce4daf558568f2633645658f565f71c5e6c9f441fd2ade5dd61b138'
+ 'a0a59226614b878e7c32890cb7c38a6fe48a97082baf4913297d4c3958a9b3ac')
prepare() {
# tarball doesn't have a root dir, extracting to $srcdir
@@ -33,11 +26,11 @@ prepare() {
sed 's@../../csoundqt/src/Scripts@/usr/share/csoundqt/Scripts@' -i src/types.h
}
-
build() {
-# for csound midi module, remove CONFIG+=rtmidi "RTMIDI_DIR=${_rtmidi}"
-# for PythonQt add CONFIG+=pythonqt
- qmake-qt4 qcs.pro CONFIG+=rtmidi "RTMIDI_DIR=${_rtmidi}"
+# Now uses RtMidi, see: http://qutecsound.sourceforge.net/pages/develop.html
+# For csound midi module, remove CONFIG+=rtmidi "RTMIDI_DIR=${_rtmidi}".
+# For PythonQt add CONFIG+=pythonqt.
+ qmake-qt4 qcs.pro CONFIG+=rtmidi "RTMIDI_DIR=${_rtmidi}"
make
}
@@ -48,8 +41,6 @@ package() {
install -Dm755 bin/CsoundQt-d-cs6 "$pkgdir"/usr/bin/csoundqt
# desktop file and icon
install -Dm644 "$srcdir"/csoundqt.desktop "$pkgdir"/usr/share/applications
- #install -Dm644 images/qtcs.png "$pkgdir"/usr/share/icons/hicolor/128x128/apps/csoundqt.png
- install -Dm644 images/qtcs.svg "$pkgdir"/usr/share/icons/hicolor/scalable/apps/csoundqt.svg
install -Dm644 images/qtcs.png "$pkgdir"/usr/share/pixmaps/csoundqt.png
install -Dm644 images/* -t "$pkgdir"/usr/share/csoundqt/images
# docs
@@ -57,6 +48,8 @@ package() {
find examples -type f -print0 | xargs -0 -n1 -i{} install -Dm644 '{}' "$pkgdir"/usr/share/doc/csoundqt/'{}'
cd src
find Examples -type f -print0 | xargs -0 -n1 -i{} install -Dm644 '{}' "$pkgdir"/usr/share/csoundqt/'{}'
-# pythonqt scripts
+# pythonqt scripts: Install these if you want added python functionality
#find Scripts -type f -print0 | xargs -0 -n1 -i{} install -Dm644 '{}' "$pkgdir"/usr/share/csoundqt/'{}'
}
+
+# vim: set tabstop=2 shiftwidth=2 expandtab
diff --git a/csoundqt.desktop b/csoundqt.desktop
index 2c9572a9c724..2fc6cf733448 100644
--- a/csoundqt.desktop
+++ b/csoundqt.desktop
@@ -1,6 +1,6 @@
[Desktop Entry]
Name=CsoundQt
-Comment=Csound Qt signal processing environment/editor
+Comment=A frontend for Csound with interactive widgets and integrated help.
Exec=csoundqt
Icon=csoundqt
Terminal=false