summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAinola2015-09-06 15:05:46 -0600
committerAinola2015-09-06 15:05:46 -0600
commite11827f8b36ae2ef28625a5dcb36d68e511cb348 (patch)
tree4a47c7dbab9bac7de8c5a26dd522e066a1f2554f
parentb9b0554597adc290db162bbbf1422e4c6a3339b9 (diff)
downloadaur-e11827f8b36ae2ef28625a5dcb36d68e511cb348.tar.gz
add mimetype and proper icons, associate .csd to csoundqt
-rw-r--r--PKGBUILD20
-rw-r--r--csoundqt-icons.tar.gzbin0 -> 242586 bytes
-rw-r--r--csoundqt-mime.xml7
-rw-r--r--csoundqt.desktop1
-rw-r--r--csoundqt.install2
5 files changed, 24 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b3b6bf8ff7fc..5b7ff72b9198 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,14 +9,19 @@ arch=('i686' 'x86_64')
url="http://qutecsound.sourceforge.net/"
license=('GPL3') # or, at your option, LGPL2
depends=('csound' 'qt4' 'csound-doc')
+makedepends=('shared-mime-info')
install="csoundqt.install"
_rtmidi=rtmidi-2.1.0
source=("http://sourceforge.net/projects/qutecsound/files/CsoundQt/${pkgver}/csoundqt-${pkgver}-src.tar.gz"
"csoundqt.desktop"
- "http://www.music.mcgill.ca/~gary/rtmidi/release/${_rtmidi}.tar.gz")
+ "http://www.music.mcgill.ca/~gary/rtmidi/release/${_rtmidi}.tar.gz"
+ "csoundqt-mime.xml"
+ "csoundqt-icons.tar.gz")
sha256sums=('873c699091e28064bc25f45a1081d583b42c4927061174f76cd8231ef1394feb'
- '4cc7e3d77ce4daf558568f2633645658f565f71c5e6c9f441fd2ade5dd61b138'
- 'a0a59226614b878e7c32890cb7c38a6fe48a97082baf4913297d4c3958a9b3ac')
+ '6d08233ee50eec15bbcb59f1edcee56626264fb37590603bc88af4764e8dda9d'
+ 'a0a59226614b878e7c32890cb7c38a6fe48a97082baf4913297d4c3958a9b3ac'
+ '2d78945761ff6f673ac93f7d879a691eb77466e73a40ef77e4a8f3c3c374d599'
+ 'd2a7319315e77cd5f694a0d861772ea09d0a10cdcbaa9e0c6751b3b72fca5982')
prepare() {
# tarball doesn't have a root dir, extracting to $srcdir
@@ -39,10 +44,12 @@ package() {
install -d "$pkgdir"/usr/{bin,share/{applications,csoundqt,doc/csoundqt}}
install -Dm755 bin/CsoundQt-d-cs6 "$pkgdir"/usr/bin/csoundqt
-# desktop file and icon
+# desktop file and icons
install -Dm644 "$srcdir"/csoundqt.desktop "$pkgdir"/usr/share/applications
- install -Dm644 images/qtcs.png "$pkgdir"/usr/share/pixmaps/csoundqt.png
- install -Dm644 images/* -t "$pkgdir"/usr/share/csoundqt/images
+ for size in 22 24 32 48 64 128 256 512; do
+ install -Dm644 "${srcdir}/${size}.png" \
+ "${pkgdir}/usr/share/icons/hicolor/${size}x${size}/apps/csoundqt.png"
+ done
# docs
install -Dm644 doc/*.pdf -t "$pkgdir"/usr/share/doc/csoundqt
find examples -type f -print0 | xargs -0 -n1 -i{} install -Dm644 '{}' "$pkgdir"/usr/share/doc/csoundqt/'{}'
@@ -50,6 +57,7 @@ package() {
find Examples -type f -print0 | xargs -0 -n1 -i{} install -Dm644 '{}' "$pkgdir"/usr/share/csoundqt/'{}'
# pythonqt scripts: Install these if you want added python functionality
#find Scripts -type f -print0 | xargs -0 -n1 -i{} install -Dm644 '{}' "$pkgdir"/usr/share/csoundqt/'{}'
+ install -Dm644 "$srcdir"/csoundqt-mime.xml "$pkgdir"/usr/share/mime/packages/csoundqt.xml
}
# vim: set tabstop=2 shiftwidth=2 expandtab
diff --git a/csoundqt-icons.tar.gz b/csoundqt-icons.tar.gz
new file mode 100644
index 000000000000..2d15fff638ec
--- /dev/null
+++ b/csoundqt-icons.tar.gz
Binary files differ
diff --git a/csoundqt-mime.xml b/csoundqt-mime.xml
new file mode 100644
index 000000000000..31def484d775
--- /dev/null
+++ b/csoundqt-mime.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
+ <mime-type type="application/x-csoundqt">
+ <comment>Csound Project</comment>
+ <glob pattern="*.csd"/>
+ </mime-type>
+</mime-info>
diff --git a/csoundqt.desktop b/csoundqt.desktop
index 2fc6cf733448..3b4e55b2d5e4 100644
--- a/csoundqt.desktop
+++ b/csoundqt.desktop
@@ -5,4 +5,5 @@ Exec=csoundqt
Icon=csoundqt
Terminal=false
Type=Application
+MimeType=application/x-csoundqt
Categories=Application;AudioVideo;Audio;
diff --git a/csoundqt.install b/csoundqt.install
index e111ef946053..97eb032bfdbe 100644
--- a/csoundqt.install
+++ b/csoundqt.install
@@ -1,5 +1,7 @@
post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
update-desktop-database -q
+ update-mime-database /usr/share/mime
}
post_upgrade() {