summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Blakeney2016-08-25 15:27:57 +1000
committerMark Blakeney2016-08-25 15:27:57 +1000
commit3cd294fbc625a3be079602167ff87c0540a68e20 (patch)
tree081f2e022ba3af2e1ddcc6b8f9ca09afb10c5d2d
parentade3ee4ba080e1f4846e264dcd6da36233d50a17 (diff)
downloadaur-3cd294fbc625a3be079602167ff87c0540a68e20.tar.gz
A few minor PKGBUILD cleanups
No actual version change, i.e. no change to end package.
-rw-r--r--.SRCINFO2
-rw-r--r--Makefile15
-rw-r--r--PKGBUILD3
3 files changed, 6 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d858ca9ad4f4..18fc820986a5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sat Feb 6 21:38:03 UTC 2016
+# Thu Aug 25 05:25:16 UTC 2016
pkgbase = cssc
pkgdesc = A clone of the Unix SCCS tool suite.
pkgver = 1.4.0
diff --git a/Makefile b/Makefile
index a7c45c6e0a62..358e7f5e1d3d 100644
--- a/Makefile
+++ b/Makefile
@@ -1,14 +1,8 @@
-pkg = cssc-1.4.0-1-x86_64.pkg.tar.xz
+nam = cssc
src = PKGBUILD
inf = .SRCINFO
-all: $(inf) $(pkg)
-
-%.tar.xz: $(src)
- makepkg -s
-
-install: $(pkg)
- pacman -U $^
+all: sum $(inf) check
$(inf): $(src)
mksrcinfo
@@ -16,13 +10,10 @@ $(inf): $(src)
check: $(src)
namcap $^
-aur: $(pkg)
- mkaurball -f
-
sum: $(src)
updpkgsums
clean:
- rm -rf $(inf) *.tar.xz *.tar.gz pkg/ src/
+ rm -rf $(inf) $(nam)-* *.tar.xz *.tar.gz pkg/ src/ *.part
# vim: se ts=4:
diff --git a/PKGBUILD b/PKGBUILD
index b1a14ec4678e..5cd09cc4898f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgver="1.4.0"
pkgrel=1
pkgdesc="A clone of the Unix SCCS tool suite."
arch=('i686' 'x86_64')
-url="http://savannah.gnu.org/projects/cssc"
+url="http://savannah.gnu.org/projects/$pkgname"
license=('GPL2')
depends=('gcc-libs' 'sh')
options=('!emptydirs')
@@ -20,6 +20,7 @@ build() {
make
}
+# Can enable this check but takes a very long time to run ..
#check() {
# cd "$srcdir/$_PKGNAME-$pkgver"
# make check