summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikołaj Baranowski2016-06-19 16:58:15 +0200
committerMikołaj Baranowski2016-06-19 16:58:15 +0200
commit3cdb558656289c258c75f2d002c1e9265eaba99e (patch)
treef65ef993d41da8d83b0622cf7a0ebeca19705828
downloadaur-3cdb558656289c258c75f2d002c1e9265eaba99e.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD31
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..244919ed7002
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = csvfilter
+ pkgdesc = Filter for csv files.
+ pkgver = 0.1.r0.g8425b0a
+ pkgrel = 1
+ url = https://github.com/mikolajb/csvfilter
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = go
+ source = csvfilter::git+https://github.com/mikolajb/csvfilter.git
+ sha256sums = SKIP
+
+pkgname = csvfilter
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7e4a83d0b515
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Mikołaj Baranowski <mikolajb@gmail.com>
+
+pkgname=csvfilter
+pkgver=0.1.r0.g8425b0a
+pkgrel=1
+pkgdesc='Filter for csv files.'
+license=('MIT')
+arch=('x86_64' 'i686')
+url='https://github.com/mikolajb/csvfilter'
+depends=()
+makedepends=('go')
+source=("${pkgname}::git+https://github.com/mikolajb/csvfilter.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${srcdir}/${pkgname}/
+ git describe --tags --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ msg2 'Compiling...'
+
+ cd ${srcdir}/${pkgname}/
+ GOPATH="$GOPATH:$srcdir" go build -o csvfilter
+}
+
+package() {
+ msg2 'Installing...'
+
+ install -Dm755 ${srcdir}/${pkgname}/csvfilter ${pkgdir}/usr/bin/csvfilter
+}