summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVojtech Horky2015-06-08 16:01:25 +0200
committerVojtech Horky2015-06-08 16:01:25 +0200
commit6426243c09a35cb06d546073fb5a81fe22667561 (patch)
treec0f7fb9a6e07aa23d7eea91e596ad364bf3b5697
downloadaur-6426243c09a35cb06d546073fb5a81fe22667561.tar.gz
Initial import
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD25
3 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..375e6b7cb2b2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = csvfix
+ pkgdesc = Command-line stream editor designed to deal with CSV data
+ pkgver = 1.5
+ pkgrel = 2
+ url = http://code.google.com/p/csvfix/
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = gcc-libs
+ source = https://bitbucket.org/neilb/csvfix/get/version-1.5.zip
+
+pkgname = csvfix
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..91a7dbc8b943
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.pkg.tar.xz
+pkg/
+src/
+version-1.5.zip
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..36ad3c9400a3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Contributor: Vojtech Horky <AUR / hotspur>
+pkgname=csvfix
+pkgver=1.5
+pkgrel=2
+pkgdesc="Command-line stream editor designed to deal with CSV data"
+url="http://code.google.com/p/csvfix/"
+arch=('i686' 'x86_64')
+license=('custom')
+depends=('gcc-libs')
+# Downloading from here because on code.google.com is not ZIP version
+# with sources (also notice the directory we cd-into)
+source=("https://bitbucket.org/neilb/${pkgname}/get/version-${pkgver}.zip")
+md5sums=('ae7e0a41e3bca3f48f08fbca60602d4c')
+
+build() {
+ cd "${srcdir}/neilb-csvfix-8ae6bdb5996e/"
+ make lin
+}
+
+package() {
+ cd "${srcdir}/neilb-csvfix-8ae6bdb5996e/"
+ install -D -m 0755 "${pkgname}/bin/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -D -m 0644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+