summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kurilo2015-06-25 23:26:09 +0300
committerAlexander Kurilo2015-06-25 23:26:09 +0300
commit439763a6ba958aaeabd379cd220025d8d81779c5 (patch)
treedd4c65116cd469b87670c2cc7e894bdf2434b80c
downloadaur-439763a6ba958aaeabd379cd220025d8d81779c5.tar.gz
Initial commit in aur4-compatible format
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD34
-rw-r--r--README.md3
4 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..abc60c4a6bac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = csvkit-git
+ pkgdesc = A suite of utilities for converting to and working with CSV.
+ pkgver = 0.9.1.gbf18815
+ pkgrel = 1
+ url = http://csvkit.readthedocs.org
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = python
+ depends = python-xlrd>=0.9.2
+ depends = python-dateutil>=2.0
+ depends = python-sqlalchemy>=0.9.3
+ depends = python-openpyxl>=2.0.3
+ depends = python-six>=1.6.1
+ source = csvkit::git://github.com/onyxfish/csvkit.git
+ md5sums = SKIP
+
+pkgname = csvkit-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f0d06db0bac5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+/csvkit-git-*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2b23204b5bef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Alexander Kurilo <alex@kurilo.me>
+# Contributor: Mariusz SzczepaƄczyk <mszczepanczyk@gmail.com>
+
+pkgname=csvkit-git
+pkgver=0.9.1.gbf18815
+pkgrel=1
+pkgdesc="A suite of utilities for converting to and working with CSV."
+arch=('any')
+url="http://csvkit.readthedocs.org"
+license=('MIT')
+makedepends=('git')
+depends=('python' 'python-xlrd>=0.9.2' 'python-dateutil>=2.0' 'python-sqlalchemy>=0.9.3' 'python-openpyxl>=2.0.3' 'python-six>=1.6.1')
+makedepends=('git')
+md5sums=('SKIP')
+source=('csvkit::git://github.com/onyxfish/csvkit.git')
+
+pkgver() {
+ cd "$srcdir/csvkit"
+ git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/csvkit"
+ # Quick and dirty fix until the author officially supports dateutil>=2.2
+ # (see https://github.com/onyxfish/csvkit/issues/370)
+ sed -i 's/python-dateutil==2.2/python-dateutil>=2.2/' setup.py
+ sed -i 's/openpyxl==2.2.0-b1/openpyxl>=2.2.0-b1/' setup.py
+}
+
+package() {
+ cd "$srcdir/csvkit"
+ python setup.py install --root="$pkgdir/"
+}
+
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..1a5dbf7d6c7c
--- /dev/null
+++ b/README.md
@@ -0,0 +1,3 @@
+[csvkit-git for AUR](https://github.com/kamazee/aur-csvkit-git)
+
+Original PKGBUILD is created by [Mariusz SzczepaƄczyk](https://github.com/mszczepanczyk)