summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kurilo2016-03-14 10:55:46 +0300
committerAlexander Kurilo2016-03-14 10:56:40 +0300
commit590cecf0acdca292d0e92cf3f956e8dfee6c35f6 (patch)
treea557e22bcff88e17c30acd019e2c1cb44b801ebc
parentc895c61be124e7c73f99733b74accd7143262707 (diff)
downloadaur-590cecf0acdca292d0e92cf3f956e8dfee6c35f6.tar.gz
Copy agate.agregations
setup.py for agate doesn't copy it itself for some reason
-rw-r--r--PKGBUILD3
1 files changed, 3 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b26bbc835f56..7cba4708bfbd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -57,6 +57,9 @@ package() {
cd "$srcdir/agate"
python setup.py install --root="$pkgdir/"
+ PYTHON_MINOR_VERSION=`python --version | cut -d ' ' -f 2 | cut -d '.' -f -2`
+ ADDREGATIONS_DIR="$pkgdir/usr/lib/python$PYTHON_MINOR_VERSION/site-packages/agate/aggregations"
+ test -d "$AGGREGATIONS_DIR" || cp --recursive "$srcdir/agate/agate/aggregations" "$ADDREGATIONS_DIR"
cd "$srcdir/agate-excel"
python setup.py install --root="$pkgdir/"