summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kurilo2016-07-08 22:08:37 +0300
committerGitHub2016-07-08 22:08:37 +0300
commitf98f8c48eddcb0304e19155b6246e7944b6e71e4 (patch)
tree38da29292b144b9f34024135fee8afdb3c3af1e7
parentbceee12678abdd55092a5d0bc0a16a8c280adaa5 (diff)
parent3e1941fbf6b225174cfc64a596ea5d4e51124eab (diff)
downloadaur-f98f8c48eddcb0304e19155b6246e7944b6e71e4.tar.gz
Merge pull request #2 from gabrielmagno/master
Clean PKGBUILD to build only csvkit
-rw-r--r--PKGBUILD47
1 files changed, 9 insertions, 38 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5ed2ea35bfc1..f5b33d286453 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,40 +3,28 @@
# Contributor: Thor K. H. <thor alfakrøll roht dott no>
pkgname=csvkit-git
-pkgver=0.9.1.r280.g48f9602
-pkgrel=3
+pkgver=0.9.1.r319.gea1e7bb
+pkgrel=4
pkgdesc="A suite of utilities for converting to and working with CSV."
arch=('any')
url="http://csvkit.readthedocs.org"
license=('MIT')
depends=(
'python'
- 'python-xlrd' # >=0.9.4 for csvkit and agate
'python-dateutil' # >=2.2
'python-sqlalchemy' # >=0.9.3
- 'python-openpyxl' # >=2.0.3 for csvkit and agate
- 'python-six' # >=1.6.1 for csvkit and agate
- 'python-isodate' # >= 0.5.4 for agate
- 'python-parsedatetime' # >=1.5 for agate
- 'python-pytimeparse' # >= 1.1.5 for agate
+ 'python-six' # >=1.6.1
+ 'python-agate' # >= 1.2.2
+ 'python-agate-excel' # >= 0.1.0
+ 'python-agate-dbf' # >= 0.1.0
)
makedepends=(
'git'
'python-setuptools'
'python-pip'
)
-md5sums=(
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
-)
-source=(
- 'csvkit::git://github.com/wireservice/csvkit.git'
- 'agate::git://github.com/wireservice/agate.git'
- 'agate-excel::git://github.com/wireservice/agate-excel.git'
- 'agate-dbf::git://github.com/wireservice/agate-dbf.git'
-)
+md5sums=('SKIP')
+source=('csvkit::git://github.com/wireservice/csvkit.git')
pkgver() {
cd "$srcdir/csvkit"
@@ -53,23 +41,6 @@ build() {
package() {
cd "$srcdir/csvkit"
- python setup.py install --root="$pkgdir/"
-
- cd "$srcdir/agate"
- python setup.py install --root="$pkgdir/"
- PYTHON_MINOR_VERSION=`python --version | cut -d ' ' -f 2 | cut -d '.' -f -2`
- ADDREGATIONS_DIR="$pkgdir/usr/lib/python$PYTHON_MINOR_VERSION/site-packages/agate/aggregations"
- test -d "$AGGREGATIONS_DIR" || cp --recursive "$srcdir/agate/agate/aggregations" "$ADDREGATIONS_DIR"
-
- cd "$srcdir/agate-excel"
- python setup.py install --root="$pkgdir/"
-
- cd "$srcdir/agate-dbf"
- python setup.py install --root="$pkgdir/"
-
- test -d "$srcdir/tmp" || mkdir "$srcdir/tmp"
- #chmod +r "$pkgdir"
- TMPDIR="$srcdir/tmp" pip install 'Babel>=2.0' dbfread --root "$pkgdir/"
- TMPDIR="$srcdir/tmp" pip install 'dbfread>=2.0.5' --root "$pkgdir/"
+ python setup.py install --root="$pkgdir/" --optimize=1
}