summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Biereigel2017-12-10 13:30:59 +0100
committerStefan Biereigel2017-12-10 13:30:59 +0100
commit596ca739b99e3675c16d0ead425a08cc7555cec0 (patch)
tree7e7d8b4868a73f0b17028759d639ea0012c3adec
downloadaur-596ca739b99e3675c16d0ead425a08cc7555cec0.tar.gz
initial commit; build from git head
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD42
-rw-r--r--fix-libdir.patch16
3 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..65f311125af7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = csxcad-git
+ pkgdesc = A C++ library to describe geometrical objects and their physical or non-physical properties.
+ pkgver = v0.6.2.r83.g21a0ea1
+ pkgrel = 1
+ url = https://github.com/thliebig/CSXCAD
+ arch = i686
+ arch = x86_64
+ license = LGPL3
+ depends = fparser
+ depends = tinyxml
+ depends = hdf5
+ depends = vtk
+ depends = boost
+ depends = cgal
+ provides = csxcad
+ conflicts = csxcad
+ source = git+https://github.com/thliebig/CSXCAD
+ source = fix-libdir.patch
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = csxcad-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e7191cae8958
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Stefan Biereigel <stefan@biereigel.de>
+
+pkgname=csxcad-git
+pkgver=v0.6.2.r83.g21a0ea1
+pkgrel=1
+pkgdesc="A C++ library to describe geometrical objects and their physical or non-physical properties."
+url="https://github.com/thliebig/CSXCAD"
+arch=('i686' 'x86_64')
+license=('LGPL3')
+depends=('fparser' 'tinyxml' 'hdf5' 'vtk' 'boost' 'cgal')
+provides=('csxcad')
+conflicts=('csxcad')
+
+source=(git+https://github.com/thliebig/CSXCAD 'fix-libdir.patch')
+md5sums=('SKIP' 'SKIP')
+
+pkgver() {
+ cd "$srcdir/CSXCAD"
+ git describe --long --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd CSXCAD
+ patch -Np1 -i ../fix-libdir.patch
+}
+
+build() {
+ cd "$srcdir/CSXCAD"
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=${pkgdir} ../
+ make
+ cd ../python
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/CSXCAD/build"
+ make install
+ cd ../python
+ python setup.py install --root=${pkgdir}
+}
diff --git a/fix-libdir.patch b/fix-libdir.patch
new file mode 100644
index 000000000000..276cebdeea3f
--- /dev/null
+++ b/fix-libdir.patch
@@ -0,0 +1,16 @@
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 8903a60..e13f098 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -98,8 +98,9 @@ TARGET_LINK_LIBRARIES( CSXCAD
+ set_target_properties(CSXCAD PROPERTIES VERSION ${LIB_VERSION_STRING}
+ SOVERSION ${LIB_VERSION_MAJOR})
+
+-INSTALL(TARGETS CSXCAD DESTINATION lib${LIB_SUFFIX})
++INSTALL(TARGETS CSXCAD DESTINATION usr/lib${LIB_SUFFIX})
++
++INSTALL(FILES ${PUB_HEADERS} DESTINATION usr/include/CSXCAD)
+
+-INSTALL(FILES ${PUB_HEADERS} DESTINATION include/CSXCAD)
+
+