summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMilosD2015-06-14 13:33:47 +0200
committerMilosD2015-06-14 13:33:47 +0200
commit1c09f158958f5367ec68c1f5cc027a71286f1418 (patch)
treebcf6cac9422ea7b63950f7cfa7f6bccddcb2cc24
downloadaur-1c09f158958f5367ec68c1f5cc027a71286f1418.tar.gz
csync2 commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD35
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1c649d4b74a9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = csync2
+ pkgdesc = Asynchronous cluster syncronisation tool based on librsync and inspired by Unison
+ pkgver = 1.34
+ pkgrel = 4
+ url = http://oss.linbit.com/csync2/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = librsync
+ depends = sqlite2
+ depends = libgcrypt
+ depends = libgpg-error
+ depends = gnutls
+ depends = libtasn1
+ backup = etc/csync2.cfg
+ source = http://oss.linbit.com/csync2/csync2-1.34.tar.gz
+ md5sums = efc8a3548996b79cef2ad76af5e93cd8
+
+pkgname = csync2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..30d068434aea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+#Maintainer : gls < ghostlovescorebg at gmail dot com >
+
+pkgname=csync2
+pkgver=1.34
+pkgrel=4
+arch=('i686' 'x86_64')
+pkgdesc="Asynchronous cluster syncronisation tool based on librsync and inspired by Unison"
+url="http://oss.linbit.com/csync2/"
+license=('GPL')
+depends=(librsync sqlite2 libgcrypt libgpg-error gnutls libtasn1)
+source=(http://oss.linbit.com/csync2/$pkgname-$pkgver.tar.gz)
+backup=(etc/csync2.cfg)
+md5sums=('efc8a3548996b79cef2ad76af5e93cd8')
+
+build() {
+
+ cd "$srcdir/$pkgname-$pkgver"
+ sed -e 's/\-1.7//g' -i ./autogen.sh
+
+ #AM_PATH_LIBGNUTLS does not exist any more
+ sed -ie 's/.*AM_PATH_LIBGNUTLS.*/PKG_CHECK_MODULES([LIBGNUTLS], [gnutls >= 1.2.0], have_gnutls=yes, have_gnutls=no)/g' configure.ac
+ sed -ie 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' configure.ac
+
+ ./autogen.sh
+ ./configure --prefix=/usr --bindir=/bin
+ make
+
+ # By default, csync2 tries to install binary to /usr/bin/sbin.
+ # This line changes Makefile and tells compiler to put binary in /usr/bin.
+ sed -ie 's/sbindir\ =\ \${exec_prefix}\/sbin/sbindir\ =\ \${exec_prefix}\/bin/g' Makefile
+
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" -name '*.la' -exec rm {} \;
+}
+# vim:set ts=2 sw=2 et: