summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorĽubomír Kučera2017-04-22 13:17:40 +0200
committerĽubomír Kučera2017-04-22 13:17:40 +0200
commitd049f8f860c1ad30f91348a38ec7c17ee5e57469 (patch)
tree6e2c5ef3071ace4fce5478ec4fc3fe3bc2bbad08
downloadaur-d049f8f860c1ad30f91348a38ec7c17ee5e57469.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD24
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c79fa3d045fa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Sat Apr 22 11:17:29 UTC 2017
+pkgbase = ct
+ pkgdesc = Container Linux Config Transpiler
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/coreos/container-linux-config-transpiler
+ arch = any
+ license = Apache
+ makedepends = git
+ makedepends = go
+ source = git+https://github.com/coreos/container-linux-config-transpiler.git#tag=v0.3.0
+ sha256sums = SKIP
+
+pkgname = ct
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1cbaa05c5e68
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*/
+*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a3e339d5f79b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Ľubomir 'The_K' Kučera <lubomir-kucera-jr-at-gmail-dot-com>
+
+pkgname=ct
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="Container Linux Config Transpiler"
+arch=('any')
+url='https://github.com/coreos/container-linux-config-transpiler'
+license=('Apache')
+makedepends=('git' 'go')
+source=("git+https://github.com/coreos/container-linux-config-transpiler.git#tag=v${pkgver}")
+sha256sums=('SKIP')
+
+build() {
+ cd "${srcdir}/container-linux-config-transpiler"
+
+ ./build
+}
+
+package() {
+ cd "${srcdir}/container-linux-config-transpiler"
+
+ install -Dm755 bin/ct "${pkgdir}/usr/bin/ct"
+}