summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoshua Hardy2017-03-13 22:42:43 +1100
committerJoshua Hardy2017-03-13 22:42:43 +1100
commitda010bec8dd4f83d2d104b481f2f49339d594ff3 (patch)
tree4f1eedb1b2a38173967e1909baa9a0ff8ff717ce
parent1572fa92abeb21aaa0aecaa684cc3e0ca2c2646b (diff)
downloadaur-da010bec8dd4f83d2d104b481f2f49339d594ff3.tar.gz
added license
-rw-r--r--.SRCINFO2
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD12
3 files changed, 30 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 27ef5cb645b6..82a99c2e136e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,7 +8,9 @@ pkgbase = ctffind4
optdepends = pdftk: for improved pdf output
optdepends = gnuplot: for improved pdf output
source = http://grigoriefflab.janelia.org/sites/all/modules/pubdnldcnt/pubdnldcnt.php?file=http://grigoriefflab.janelia.org/sites/default/files/ctffind-4.1.5-linux64.tar.gz
+ source = LICENSE
md5sums = 4e5ffbe72097819d12945f6392e22dcc
+ md5sums = SKIP
pkgname = ctffind4
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..9d8c11215816
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+The Janelia Farm Research Campus Software Copyright 1.1
+
+Copyright (c) 2014, Howard Hughes Medical Institute, All rights reserved.
+
+Redistribution and use in source and binary forms, with or without modification, are permitted provided that
+the following conditions are met:
+
+Redistributions of source code must retain the above copyright notice, this list of conditions and the
+following disclaimer.
+Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the
+following disclaimer in the documentation and/or other materials provided with the distribution.
+Neither the name of the Howard Hughes Medical Institute nor the names of its contributors may be used to
+endorse or promote products derived from this software without specific prior written permission.
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED
+WARRANTIES, INCLUDING, BUT NOT LIMITED TO, ANY IMPLIED WARRANTIES OF MERCHANTABILITY, NON-INFRINGEMENT, OR
+FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE
+LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; REASONABLE ROYALTIES;
+OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE,
+EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
index e0ac38bb3668..f49c92b16abe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,18 +9,20 @@ license=('GPL')
depends=('')
optdepends=('pdftk: for improved pdf output'
'gnuplot: for improved pdf output')
-source=("http://grigoriefflab.janelia.org/sites/all/modules/pubdnldcnt/pubdnldcnt.php?file=http://grigoriefflab.janelia.org/sites/default/files/ctffind-$pkgver-linux64.tar.gz")
-md5sums=('4e5ffbe72097819d12945f6392e22dcc')
+source=("http://grigoriefflab.janelia.org/sites/all/modules/pubdnldcnt/pubdnldcnt.php?file=http://grigoriefflab.janelia.org/sites/default/files/ctffind-$pkgver-linux64.tar.gz" 'LICENSE')
+md5sums=('4e5ffbe72097819d12945f6392e22dcc' 'SKIP')
options=()
-#prepare () {
-#}
+prepare () {
+ echo "The program CTFFIND3 is an updated version of the program CTFFIND2, which was developed in 1998 by Nikolaus Grigorieff at the MRC Laboratory of Molecular Biology in Cambridge, UK with financial support from the MRC. This software is licensed under the terms of the Janelia Research Campus Software Copyright 1.1."
+}
#build() {
#}
package() {
cd "$srcdir/bin"
- install -d $pkgdir/usr/bin/
+ install -d $pkgdir/usr/bin/ "${pkgdir}/usr/share/licenses/${pkgname}"
install -D -m755 ctffind $pkgdir/usr/bin/.
install -D -m755 ctffind_plot_results.sh $pkgdir/usr/bin/.
+ install -D -m644 ${srcdir}/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}