summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortsingkwai2022-01-02 14:36:45 +0800
committertsingkwai2022-01-02 14:36:45 +0800
commit50c93169007bf2646aac04b57d4acdb5a2cc21e1 (patch)
treee2e93c50ee64b333ba9242b608178e92d3f0d288
downloadaur-50c93169007bf2646aac04b57d4acdb5a2cc21e1.tar.gz
init
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD19
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..267f6c53cb5a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = ctpkg
+ pkgdesc = A bridge for different package managers , and a userland package manager included , written in progynosh(fish)
+ pkgver = 31
+ pkgrel = 31
+ url = https://ruzhtw.top/pages/projects/CenterLinux/ctpm
+ arch = x86_64
+ license = GPL-3.0 License
+ depends = fish
+ depends = sudo
+ provides = ctpkg
+ source = https://raw.githubusercontent.com/TeaHouseLab/ctpkg/main/app
+ sha256sums = SKIP
+
+pkgname = ctpkg
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..95f77000768d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: TeaHouseLab(aka. Tsingkwai) <tsingkwai at ruzh dot top>
+pkgname="ctpkg"
+pkgver="31"
+pkgrel="31"
+pkgdesc="A bridge for different package managers , and a userland package manager included , written in progynosh(fish)"
+arch=("x86_64")
+url="https://ruzhtw.top/pages/projects/CenterLinux/ctpm"
+depends=("fish" "sudo")
+license=("GPL-3.0 License")
+provides=("ctpkg")
+source=("https://raw.githubusercontent.com/TeaHouseLab/ctpkg/main/app")
+sha256sums=("SKIP")
+package() {
+ mkdir -p "${pkgdir}/usr/bin"
+ cp "${srcdir}/app" "${pkgdir}/usr/bin/ctpkg"
+ chmod +x "${pkgdir}/usr/bin/ctpkg"
+ rm ../app
+ }
+