summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortsingkwai2022-01-30 14:28:16 +0800
committertsingkwai2022-01-30 14:28:16 +0800
commit74e87b5398be8b77bf213b57ff5270a7fa4b9aa0 (patch)
tree8695b3eb8e89f1dc3905279f90421fd1233c0585
parent6392bdd4b7f5b3f8509f865476d3ed580a4b75b4 (diff)
downloadaur-74e87b5398be8b77bf213b57ff5270a7fa4b9aa0.tar.gz
Begonia@build2
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
-rw-r--r--hooks.install8
3 files changed, 13 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d0ea3913c365..3d5454b9d3e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,12 +3,13 @@ pkgbase = ctpkg
pkgver = 49
pkgrel = 1
url = https://ruzhtw.top/pages/projects/CenterLinux/CTPM
+ install = hooks.install
arch = x86_64
license = GPL-3.0 License
depends = fish
depends = sudo
provides = ctpkg
- source = https://raw.githubusercontent.com/TeaHouseLab/ctpkg/main/app
+ source = https://cdngit.ruzhtw.top/pkghub/ctpkg
sha256sums = SKIP
pkgname = ctpkg
diff --git a/PKGBUILD b/PKGBUILD
index ff1b8b63b0e0..e33dcba19189 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,12 +8,11 @@ url="https://ruzhtw.top/pages/projects/CenterLinux/CTPM"
depends=("fish" "sudo")
license=("GPL-3.0 License")
provides=("ctpkg")
-source=("https://raw.githubusercontent.com/TeaHouseLab/ctpkg/main/app")
+source=("https://cdngit.ruzhtw.top/pkghub/ctpkg")
sha256sums=("SKIP")
+install='hooks.install'
package() {
- mkdir -p "${pkgdir}/usr/bin"
- cp "${srcdir}/app" "${pkgdir}/usr/bin/ctpkg"
- chmod +x "${pkgdir}/usr/bin/ctpkg"
+ install -m755 -D "${srcdir}/ctpkg" "${pkgdir}/usr/bin"
rm ../app
}
diff --git a/hooks.install b/hooks.install
new file mode 100644
index 000000000000..9e37d48d0a9e
--- /dev/null
+++ b/hooks.install
@@ -0,0 +1,8 @@
+pre_remove() {
+/usr/bin/ctpkg ctpm p sys ctpkg
+}
+
+op=$1
+shift
+
+$op "$@"