summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorusrmusicman2021-02-07 11:50:56 -0500
committerusrmusicman2021-02-07 11:50:56 -0500
commit1fec136071ca36ed6b7f63191283155fd5d9f59e (patch)
treee405b6782bb88ca25896fab082fef0c0451c81d6
downloadaur-1fec136071ca36ed6b7f63191283155fd5d9f59e.tar.gz
initial release
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD49
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a866c20c1485
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ctrecordings-plugin-collection
+ pkgdesc = Cut Through Recordings Plugin Collection.
+ pkgver = 20210205
+ pkgrel = 1
+ url = https://www.cutthroughrecordings.com/downloads
+ arch = x86_64
+ groups = pro-audio
+ groups = vst-plugins
+ groups = lv2-plugins
+ license = EULA
+ depends = glibc
+ depends = libcurl-gnutls
+
+pkgname = ctrecordings-plugin-collection
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..36115d688947
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer Alexander Mcmillan <linuxguy93@gmail.com>
+
+pkgname=ctrecordings-plugin-collection
+pkgver=$(date +%Y%m%d)
+pkgrel=1
+pkgdesc="Cut Through Recordings Plugin Collection."
+arch=('x86_64')
+url="https://www.cutthroughrecordings.com/downloads"
+license=('EULA')
+groups=('pro-audio' 'vst-plugins' 'lv2-plugins')
+depends=('glibc' 'libcurl-gnutls')
+
+package() {
+ cd $srcdir
+ ## Install Plugins VST3 Plugins
+ mkdir -p $pkgdir/usr/lib/vst3
+ for vst3 in convergence entropy epicpress faradelay m4compressor popss; do
+ if [[ -f `xdg-user-dir DOWNLOAD`/$vst3-LinuxVST3-64Bit.zip ]]; then
+ ln -srf `xdg-user-dir DOWNLOAD`/$vst3-LinuxVST3-64Bit.zip $srcdir/$vst3-LinuxVST3-64Bit.zip
+ unzip $vst3-LinuxVST3-64Bit.zip
+ cp *.vst3 $pkgdir/usr/lib/vst3
+ chmod +x $pkgdir/usr/lib/vst3/*.vst3
+ fi
+ done
+ ## Install Plugins VST Plugins
+ mkdir -p $pkgdir/usr/lib/vst
+ for vst in convergence entropy epicpress faradelay m4compressor popss; do
+ if [[ -f `xdg-user-dir DOWNLOAD`/$vst-LinuxVST-64Bit.zip ]]; then
+ ln -srf `xdg-user-dir DOWNLOAD`/$vst-LinuxVST-64Bit.zip $srcdir/$vst-LinuxVST-64Bit.zip
+ unzip $vst-LinuxVST-64Bit.zip
+ cp *.so $pkgdir/usr/lib/vst
+ chmod +x $pkgdir/usr/lib/vst/*.so
+ fi
+ done
+ ## Install Plugins LV2 Plugins
+ mkdir -p $pkgdir/usr/lib/lv2
+ for lv2 in convergence entropy epicpress faradelay m4compressor popss; do
+ if [[ -f `xdg-user-dir DOWNLOAD`/$lv2-LinuxLV2-64Bit.zip ]]; then
+ ln -srf `xdg-user-dir DOWNLOAD`/$lv2-LinuxLV2-64Bit.zip $srcdir/$lv2-LinuxLV2-64Bit.zip
+ unzip $lv2-LinuxLV2-64Bit.zip
+ if [[ -d $srcdir/ctrecordings-$lv2.LV2 ]]; then
+ cp -r $srcdir/ctrecordings-$lv2.LV2 $pkgdir/usr/lib/lv2/ctrecordings-$lv2.lv2
+ fi
+ if [[ -d $srcdir/POPSoundShaper.lv2 ]]; then
+ cp -r $srcdir/POPSoundShaper.lv2 $pkgdir/usr/lib/lv2/POPSoundShaper.lv2
+ fi
+ fi
+ done
+}