summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorspy2023-01-08 22:57:30 +0100
committerspy2023-01-08 22:57:30 +0100
commit65571f224dfafad09eaa816870df55c5d1103808 (patch)
tree49e9dcef46ae8d9b6f792f20acd5159e366e24e8
downloadaur-65571f224dfafad09eaa816870df55c5d1103808.tar.gz
init
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD45
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..466ac5d5d87f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,10 @@
+pkgbase = ctris-git
+ pkgdesc = Tetris clone in terminal colorzied
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/spynetS/ctris
+ arch = x86_64
+ license = GPL-2.0
+ makedepends = gcc
+
+pkgname = ctris-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0040f9aed7d1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Alfred Roos alfred@stensatter.se
+pkgname=ctris-git
+pkgver=1.0.0
+pkgrel=1
+epoch=
+pkgdesc="Tetris clone in terminal colorzied"
+arch=(x86_64)
+url="https://github.com/spynetS/ctris"
+license=('GPL-2.0')
+groups=()
+depends=()
+makedepends=(gcc)
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=()
+noextract=()
+md5sums=()
+validpgpkeys=()
+
+prepare() {
+ git clone https://github.com/spynetS/ctris.git ctris
+}
+
+build() {
+ cd ctris
+ gcc ./src/main.c
+}
+
+package() {
+ cd ctris
+ install -Dm755 ./a.out "$pkgdir/usr/bin/ctris"
+ # export lctr=/user/bin/lctr
+}