summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorspy2023-01-09 00:27:01 +0100
committerspy2023-01-09 00:27:01 +0100
commit52385fd1739d4f02f43f4b5753ffee320c98b577 (patch)
tree080cb41595059bff9f66c40a26aa56270e7e0a5f
downloadaur-52385fd1739d4f02f43f4b5753ffee320c98b577.tar.gz
init
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD45
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ad906b8f2e2c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,10 @@
+pkgbase = ctrisr-git
+ pkgdesc = Tetris clone in terminal colorzied
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/spynetS/ctrisr
+ arch = x86_64
+ license = GPL-2.0
+ makedepends = gcc
+
+pkgname = ctrisr-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0d8673f772c7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Alfred Roos alfred@stensatter.se
+pkgname=ctrisr-git
+pkgver=1.0.0
+pkgrel=1
+epoch=
+pkgdesc="Tetris clone in terminal colorzied"
+arch=(x86_64)
+url="https://github.com/spynetS/ctrisr"
+license=('GPL-2.0')
+groups=()
+depends=()
+makedepends=(gcc)
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=()
+noextract=()
+md5sums=()
+validpgpkeys=()
+
+prepare() {
+ git clone https://github.com/spynetS/ctrisr.git ctrisr
+}
+
+build() {
+ cd ctrisr
+ gcc ./src/main.c
+}
+
+package() {
+ cd ctrisr
+ install -Dm755 ./a.out "$pkgdir/usr/bin/ctrisr"
+ # export lctr=/user/bin/lctr
+}