summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-06-10 05:22:19 -0600
committerBrian Bidulock2015-06-10 05:22:19 -0600
commitf7d477b157eb93003de898215e6b74c95d3cbd12 (patch)
tree061187cca348ba3b5645d2f133d323bb8a5713da
downloadaur-f7d477b157eb93003de898215e6b74c95d3cbd12.tar.gz
initial version
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD41
-rw-r--r--copyright13
3 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9e84d83970bd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = ctwm-git
+ pkgdesc = Claude's Tab Window Manager
+ pkgver = 3.8.2.r527.ga7a2860
+ pkgrel = 1
+ url = http://ctwm.org/
+ arch = i686
+ arch = x86_64
+ license = custom:MIT/X Consortium
+ makedepends = git
+ makedepends = cmake
+ depends = libxmu
+ depends = libxpm
+ depends = libjpeg
+ provides = ctwm
+ conflicts = ctwm
+ backup = usr/lib/X11/twm/system.ctwmrc
+ source = ctwm-git::git+https://github.com/fullermd/ctwm-mirror.git
+ source = copyright
+ md5sums = SKIP
+ md5sums = 27dfbec8866ff55e54f6232a2d2d2de8
+
+pkgname = ctwm-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..61faf57ab733
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+#Maintainer: Brian Bidulock <bidulock@openss7.org>
+
+pkgname=ctwm-git
+pkgver=3.8.2.r527.ga7a2860
+pkgrel=1
+pkgdesc="Claude's Tab Window Manager"
+arch=('i686' 'x86_64')
+url="http://ctwm.org/"
+license=('custom:MIT/X Consortium')
+provides=('ctwm')
+conflicts=('ctwm')
+depends=('libxmu' 'libxpm' 'libjpeg')
+makedepends=('git' 'cmake')
+backup=('usr/lib/X11/twm/system.ctwmrc')
+source=("$pkgname::git+https://github.com/fullermd/ctwm-mirror.git"
+ copyright)
+md5sums=('SKIP'
+ '27dfbec8866ff55e54f6232a2d2d2de8')
+
+pkgver() {
+ cd $pkgname
+ git describe --long --tags --match 'ctwm-*' | sed -r 's,^ctwm-,,;s,([^-]*-g),r\1,;s,[-_],.,g'
+}
+
+build() {
+ cd $pkgname
+ mkdir build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
+}
+
+package() {
+ cd $pkgname
+ cd build
+ sed -e 's,/lib64/,/lib/,g' -i cmake_install.cmake
+ make DESTDIR="$pkgdir" install
+ install -Dm0644 "$srcdir/copyright" "$pkgdir/usr/share/licenses/$pkgname/copyright"
+}
+
+# vim:set et sw=2:
diff --git a/copyright b/copyright
new file mode 100644
index 000000000000..7030909d2c02
--- /dev/null
+++ b/copyright
@@ -0,0 +1,13 @@
+COPYRIGHT
+
+Portions copyright 1988 Evans & Sutherland Computer Corporation; portions
+copyright 1989 Hewlett-Packard Company and the Massachusetts Institute of
+Technology, See X(1) for a full statement of rights and permissions.
+
+AUTHORS
+
+Tom LaStrange, Solbourne Computer; Jim Fulton, MIT X Consortium;
+Steve Pitschke, Stardent Computer; Keith Packard, MIT X Consortium;
+Dave Sternlicht, MIT X Consortium; Dave Payne, Apple Computer;
+Claude Lecommandeur, Swiss Polytechnical Institute of Lausanne (lecom@sic.epfl.ch);
+Richard Levitte (richard@levitte.org). \ No newline at end of file