summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWeitian Leung2016-04-18 22:08:09 +0800
committerWeitian Leung2016-04-18 22:08:09 +0800
commit720ced86b8d662744cfa6778d975825ed711c472 (patch)
tree3ec2d2eeab695fed75b6e20960f3e4c975258695
downloadaur-720ced86b8d662744cfa6778d975825ed711c472.tar.gz
first release
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..627cc0f3a3e0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Mon Apr 18 14:05:12 UTC 2016
+pkgbase = cu-notify-git
+ pkgdesc = Auto check ArchLinux package updates, popup notification if new updates available
+ pkgver = r2
+ pkgrel = 1
+ url = https://github.com/timxx/cu-notify
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = libnotify
+ depends = pacman
+ source = cu-notify-git::git+https://github.com/timxx/cu-notify.git
+ md5sums = SKIP
+
+pkgname = cu-notify-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dc7525350df6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Weitian Leung <weitianleung[at]gmail[dot]com>
+
+pkgname=cu-notify-git
+pkgver=r2
+pkgrel=1
+pkgdesc="Auto check ArchLinux package updates, popup notification if new updates available"
+arch=(any)
+url="https://github.com/timxx/cu-notify"
+license=('MIT')
+depends=('libnotify' 'pacman')
+makedepends=('git')
+source=("$pkgname::git+https://github.com/timxx/cu-notify.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "r%s" "$(git rev-list --count HEAD)"
+}
+
+package() {
+ cd $srcdir/$pkgname
+ install -d "$pkgdir/usr/bin"
+ cp cu-notify "$pkgdir/usr/bin"
+
+ install -d "$pkgdir/etc/xdg/autostart"
+ cp cu-notify-autostart.desktop "$pkgdir/etc/xdg/autostart"
+}