summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Straube2016-06-10 16:05:39 +0200
committerMichael Straube2016-06-10 16:05:39 +0200
commit40f14492f5fb8c0c3d7a3d7741ba0a73a7e28d27 (patch)
tree3f3aaffef041fc066cb7ccb369e4e3128fefa475
downloadaur-40f14492f5fb8c0c3d7a3d7741ba0a73a7e28d27.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e1584bef423e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = cubetwister
+ pkgdesc = Your companion to your Rubik's Cube, a highly configurable editor for cube scripts
+ pkgver = 2.0.155
+ pkgrel = 1
+ url = https://www.randelshofer.ch/cubetwister
+ arch = any
+ license = CCPL:by-3.0
+ depends = bash
+ depends = java-runtime
+ source = https://www.randelshofer.ch/cubetwister/files/cubetwister-2.0.155.zip
+ sha1sums = 6eb906af88163fcc6675a1b7304d05f2f689a869
+
+pkgname = cubetwister
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bb050ea0827e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Michael Straube <m.s.online gmx.de>
+
+pkgname=cubetwister
+pkgver=2.0.155
+pkgrel=1
+pkgdesc="Your companion to your Rubik's Cube, a highly configurable editor for cube scripts"
+arch=('any')
+license=('CCPL:by-3.0')
+url="https://www.randelshofer.ch/cubetwister"
+depends=('bash' 'java-runtime')
+source=("https://www.randelshofer.ch/cubetwister/files/$pkgname-$pkgver.zip")
+sha1sums=('6eb906af88163fcc6675a1b7304d05f2f689a869')
+
+prepare() {
+ printf '#!/bin/bash\njava -jar /usr/share/cubetwister/CubeTwister.jar "$@"' > cubetwister
+}
+
+package() {
+ cd "CubeTwister $pkgver"
+
+ install -dm755 "$pkgdir/usr/share/cubetwister"
+ cp -r * "$pkgdir/usr/share/cubetwister/"
+
+ install -Dm755 "$srcdir/cubetwister" "$pkgdir/usr/bin/cubetwister"
+}