summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosef Miegl2019-02-07 17:32:47 +0100
committerJosef Miegl2019-02-07 17:32:47 +0100
commit0ee30fcaa2ff3e7381a47f69b685f8a3e98d001d (patch)
tree2803d163513446ceaf9288371289f183bf15e880
parentb1dfccc2660575c39f0fd73df02f4b42aea2cef5 (diff)
downloadaur-0ee30fcaa2ff3e7381a47f69b685f8a3e98d001d.tar.gz
style
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD42
2 files changed, 19 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 15ac8ca46f10..21da79f24b57 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,6 +6,8 @@ pkgbase = cubicsdr
install = cubicsdr.install
arch = i686
arch = x86_64
+ arch = aarch64
+ arch = armv7h
license = GPL
makedepends = git
makedepends = cmake
@@ -25,7 +27,7 @@ pkgbase = cubicsdr
optdepends = soapyplutosdr: support for PlutoSDR
optdepends = soapyremote: use any SoapySDR device remotely over network
optdepends = hamlib: hamlib support
- source = https://github.com/cjcliffe/CubicSDR/archive/0.2.5.tar.gz
+ source = cubicsdr-0.2.5.tar.gz::https://github.com/cjcliffe/CubicSDR/archive/0.2.5.tar.gz
sha256sums = 5cb44c110fcbbb70a468b7fa402cf35f84d8901b3dd42d471a90ac3f5db00f4d
pkgname = cubicsdr
diff --git a/PKGBUILD b/PKGBUILD
index 14f78ec3b5f7..d79277dbec32 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,35 +9,23 @@ pkgname=cubicsdr
pkgver=0.2.5
pkgrel=2
pkgdesc="Cross-Platform Software-Defined Radio Application"
-arch=('i686' 'x86_64')
+arch=('i686' 'x86_64' 'aarch64' 'armv7h')
url="https://github.com/cjcliffe/CubicSDR"
license=('GPL')
-depends=(
- 'libpulse'
- 'wxgtk2-dev'
- 'wxgtk-common-dev'
- 'soapysdr'
- 'liquid-dsp'
-)
-optdepends=(
- 'fftw: FFTW support'
- 'soapyrtlsdr: support for RTL-SDR (RTL2832U) dongles'
- 'soapyairspy: support for Airspy R2 and Airspy Mini'
- 'soapysdrplay: support for SDRplay RSP'
- 'soapyhackrf: support for HackRF'
- 'limesuite: support for LimeSDR'
- 'soapyosmo: support for MiriSDR and RFSpace'
- 'soapyplutosdr: support for PlutoSDR'
- 'soapyremote: use any SoapySDR device remotely over network'
- 'hamlib: hamlib support'
-)
-makedepends=(
- 'git'
- 'cmake'
- 'libicns'
-)
+depends=('libpulse' 'wxgtk2-dev' 'wxgtk-common-dev' 'soapysdr' 'liquid-dsp')
+optdepends=('fftw: FFTW support'
+ 'soapyrtlsdr: support for RTL-SDR (RTL2832U) dongles'
+ 'soapyairspy: support for Airspy R2 and Airspy Mini'
+ 'soapysdrplay: support for SDRplay RSP'
+ 'soapyhackrf: support for HackRF'
+ 'limesuite: support for LimeSDR'
+ 'soapyosmo: support for MiriSDR and RFSpace'
+ 'soapyplutosdr: support for PlutoSDR'
+ 'soapyremote: use any SoapySDR device remotely over network'
+ 'hamlib: hamlib support')
+makedepends=('git' 'cmake' 'libicns')
install="${pkgname}.install"
-source=("https://github.com/cjcliffe/CubicSDR/archive/$pkgver.tar.gz")
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/cjcliffe/CubicSDR/archive/${pkgver}.tar.gz")
sha256sums=('5cb44c110fcbbb70a468b7fa402cf35f84d8901b3dd42d471a90ac3f5db00f4d')
build() {
@@ -65,3 +53,5 @@ package() {
cd "${srcdir}/CubicSDR-${pkgver}/build"
make DESTDIR="${pkgdir}" install
}
+
+# vim:set ts=2 sw=2 et: