summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosef Miegl2018-12-29 14:24:37 +0100
committerJosef Miegl2018-12-29 14:24:37 +0100
commit229cd0bcd9b2b1987713010e7fd95297845b179b (patch)
tree0b05dbc06126815ea92fba9c39ec5a535ebe0644
downloadaur-229cd0bcd9b2b1987713010e7fd95297845b179b.tar.gz
Initial commit
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD47
-rw-r--r--cubicsdr.desktop10
-rw-r--r--cubicsdr.pngbin0 -> 81157 bytes
4 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1396c9bfaa21
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = cubicsdr
+ pkgdesc = Cross-Platform Software-Defined Radio Application
+ pkgver = 0.2.5
+ pkgrel = 1
+ url = https://github.com/cjcliffe/CubicSDR
+ arch = x86_64
+ license = GPL
+ optdepends = soapyrtlsdr: support for RTL-SDR (RTL2832U) dongles
+ optdepends = soapyairspy-git: support for Airspy R2 and Airspy Mini
+ optdepends = soapysdrplay-git: support for SDRplay RSP
+ optdepends = soapyhackrf-git: support for HackRF
+ optdepends = limesuite: support for LimeSDR
+ optdepends = soapylms7-git: support for LimeSDR
+ optdepends = soapyosmo: support for MiriSDR and RFSpace
+ optdepends = soapyplutosdr-git: support for PlutoSDR
+ optdepends = soapyremote: use any SoapySDR device remotely over network
+ options = !strip
+ source = https://github.com/cjcliffe/CubicSDR/releases/download/0.2.5/CubicSDR-0.2.5-x86_64.AppImage
+ source = cubicsdr.desktop
+ source = cubicsdr.png
+ sha256sums = 52294f870659a1586182769446429d87a11b1821a882a67d846ca4a5170a77b4
+ sha256sums = 98dc7ec85637b44505cb1aa51f06fd4171c0d586968f653758fa216684d73de8
+ sha256sums = 063b0aeca2cf34f682bc33e9de49a704d5f8a56ba12a1acd75e7d6a2f99fe789
+
+pkgname = cubicsdr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..12b0d59a8979
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Josef Miegl <josef@miegl.cz>
+# Contributor: Romain Porte <microjoe@microjoe.org>
+# Contributor: Michal Krenek (Mikos) <m.krenek@gmail.com>
+# Contributor: valvetime <valvetimepackages@gmail.com>
+# Contributor: Dan McCurry <dan.mccurry at linux dot com>
+# Contributor: Tom Swartz <tom@tswartz.net>
+
+pkgname=cubicsdr
+pkgver=0.2.5
+pkgrel=1
+pkgdesc="Cross-Platform Software-Defined Radio Application"
+arch=('x86_64')
+options=(!strip)
+url="https://github.com/cjcliffe/CubicSDR"
+license=('GPL')
+depends=()
+optdepends=(
+ 'soapyrtlsdr: support for RTL-SDR (RTL2832U) dongles'
+ 'soapyairspy-git: support for Airspy R2 and Airspy Mini'
+ 'soapysdrplay-git: support for SDRplay RSP'
+ 'soapyhackrf-git: support for HackRF'
+ 'limesuite: support for LimeSDR'
+ 'soapylms7-git: support for LimeSDR'
+ 'soapyosmo: support for MiriSDR and RFSpace'
+ 'soapyplutosdr-git: support for PlutoSDR'
+ 'soapyremote: use any SoapySDR device remotely over network'
+)
+_file="CubicSDR-$pkgver-x86_64.AppImage"
+source=("https://github.com/cjcliffe/CubicSDR/releases/download/$pkgver/$_file" "cubicsdr.desktop" "cubicsdr.png")
+sha256sums=('52294f870659a1586182769446429d87a11b1821a882a67d846ca4a5170a77b4'
+ '98dc7ec85637b44505cb1aa51f06fd4171c0d586968f653758fa216684d73de8'
+ '063b0aeca2cf34f682bc33e9de49a704d5f8a56ba12a1acd75e7d6a2f99fe789')
+
+build() {
+ :
+}
+
+package() {
+ cd $pkgdir
+ install -d usr/lib/
+ install -d usr/bin/
+ ln -s usr/lib/$pkgname/$_file usr/bin/$pkgname
+
+ install -D -m755 $srcdir/$_file usr/lib/$pkgname/$_file
+ install -D -m644 $srcdir/$pkgname.desktop usr/share/applications/$pkgname.desktop
+ install -D -m644 $srcdir/$pkgname.png usr/share/pixmaps/$pkgname.png
+}
diff --git a/cubicsdr.desktop b/cubicsdr.desktop
new file mode 100644
index 000000000000..750afd3f116a
--- /dev/null
+++ b/cubicsdr.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Type=Application
+Exec=cubicsdr
+Icon=cubicsdr
+Terminal=false
+Name=CubicSDR
+GenericName=CubicSDR
+Comment=Software-Defined Radio Application
+Categories=Science;HamRadio;DataVisualization;
+
diff --git a/cubicsdr.png b/cubicsdr.png
new file mode 100644
index 000000000000..9c45d7a98449
--- /dev/null
+++ b/cubicsdr.png
Binary files differ