summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-02-29 16:46:57 +0800
committerzxp198210052024-02-29 16:46:57 +0800
commit266fc028b71c0b76656773258961265fc574ebaf (patch)
treea959a8f385c705fc2e1accfb861cd172c67f1408
parent66372c660421fba8cc419ab07e61349c69469b64 (diff)
downloadaur-266fc028b71c0b76656773258961265fc574ebaf.tar.gz
fix errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
-rw-r--r--cubytext.sh10
3 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9034cdef74dd..75a964422ebc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cubytext-bin
pkgdesc = An open-source knowledge management app.
pkgver = 0.0.4
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/vincentdchan/CubyText
arch = x86_64
license = MIT
@@ -15,6 +15,6 @@ pkgbase = cubytext-bin
source = cubytext.sh
sha256sums = bd0ff4fdbbeaa30ab532d7efb00b7dc9962eaa87826fa7ee80727cf518a36566
sha256sums = db7050c50a29912ab18366ac4d340da6359df6e8ad1c31bc019af5b707a69aee
- sha256sums = d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231
+ sha256sums = f80acf84a87f3f50d7c4e2ed22f4d0e8b09dd98a6c26253f2524e5413771eab1
pkgname = cubytext-bin
diff --git a/PKGBUILD b/PKGBUILD
index e7ce9e0fb735..832ff1101b20 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=cubytext-bin
pkgver=0.0.4
_electronversion=19
-pkgrel=1
+pkgrel=2
pkgdesc="An open-source knowledge management app."
arch=('x86_64')
url="https://github.com/vincentdchan/CubyText"
@@ -21,13 +21,13 @@ source=(
)
sha256sums=('bd0ff4fdbbeaa30ab532d7efb00b7dc9962eaa87826fa7ee80727cf518a36566'
'db7050c50a29912ab18366ac4d340da6359df6e8ad1c31bc019af5b707a69aee'
- 'd4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
+ 'f80acf84a87f3f50d7c4e2ed22f4d0e8b09dd98a6c26253f2524e5413771eab1')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
- -e "s|@appasar@|app|g" \
+ -e "s|@runname@|app|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
- bsdtar -xf "${srcdir}/data.tar.zst"
+ bsdtar -xf "${srcdir}/data."*
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
diff --git a/cubytext.sh b/cubytext.sh
index aacd8f895847..e6784b369c25 100644
--- a/cubytext.sh
+++ b/cubytext.sh
@@ -1,15 +1,15 @@
#!/bin/sh
set -e
_APPDIR="/usr/lib/@appname@"
-_ASAR="${_APPDIR}/@appasar@"
+_RUNNAME="${_APPDIR}/@runname@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
+export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_ASAR}" "$@"
+ exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
else
- exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
-fi
-exit \ No newline at end of file
+ exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+fi \ No newline at end of file